Autocompletion not working properly

Autocompletion not working properly

I was in Studio and scripting. But autocompletion won’t work properly.

Autocompletion is working in this case. As I’m localizing object (Part) inside Workspace.

Autocompletion isn’t working in this case. In this, I wanna change the transparency of the object (Part).

At first video. Autocompletion will work as usual and give me suggestions on what to add next. But in the second video. It will only pop up while I’m writing :

hello.Transparency = 0.8

It won’t give me suggestions for Transparency or any other “elements”. I see this as a huge issue for me. I use suggestions while scripting as they help me to locate myself while I’m writing the script.

What I tried to do

  • I tried to reset all settings in Roblox Studio.
  • I tried to re-install Roblox Studio
  • I tried to search for It. Couldn’t find anything.
  • I tried disabling and enabling Roblox Studio autocompletion to see If It’s bugged or not.

I really can’t figure out why is this even happening. It always worked for me and now It doesn’t. I will be thankful for any help.

I tried to post It as a bug of Roblox Studio. But It won’t let me. So I took It here.

i guess its a bug since i saw another post with the same problem and i also have it and its FRUSTRATING i guess the problem happens when you have an object in a variable

Mhm. I tried It now. When you write like this your whole script:

script.Parent.Hello.Transparency = 0.8
script.Parent.Hello.Color = Color3.fromRGB(25, 25, 25)

Then It will show up. But If like this:

local hello = script.Parent.Hello

hello.Transparency = 0.8

Then It won’t show up. (Gabs aren’t affecting anything.)

ah yes same prolem for me to so i guess its a bug