Automatic end system not coming up

so end or end) in scripts used to show up automatically for me before but now it does not work, i need it because it really helped me in scripting because im a beginner
so basically when i used to write


end) ---this used to show up automatically after i press enter

but now it does not and i get confused i dont know if i did something with the settings or something and i also dont know if this is happening with only me
thanks for helping


It has probably something to do with your Roblox Studio settings.
Try to check or uncheck some of the boxes you find here:
Studio - studio settings - studio - script editor OR (alt + S) - studio - script editor.

Likely “Format On Type”, “Auto Closing Brackets” or even multiple boxes.

1 Like

i tried them, they both are enabled but its not coming up and my auto intend rule is also not working despite it being set on absolute,

I wouldn’t know what the solution is as I previously haven’t been changing studio settings much or experiencing such problem, but I can only tell you what I would do if I were you. First, here is screenshot of my settings: try to mirror them and see if it helps (don’t forget to restart your Studio of course).

After trying this method, I would reset all settings (and later Studio itself):

If none of that worked, I would proceed to the following potential solution. -----------------------------

Since I don’t have many custom settings currently, I would save all my work and move to reinstalling. I would make sure that all of my work is saved manually somewhere safely (without relying on autosave) and uninstall Studio, maybe including Roblox Player. You can simply uninstall the program through Control Panel (maybe try that before next steps), but its process doesn’t include removing many no longer needed program files, which you will have to remove manually, as they may include some settings etc. By searching with keywords “complete program removal” and similar you can find more about removing these files manually. A good alternative would be third party programs (like IObit uninstaller, Wise program uninstaller and others), which are often quite reliable (still download at your own risk and take care of potential malware[!]), and remove those files for you. After that, I would simply go to Roblox official website and install both Roblox programs again.

If you wish to find another way to solve this or none of these work, please notify me and we’ll find another solution.

Good luck! :slight_smile:


none of this works, idk why whenever i watch a roblox studio tutorial it works for literally everyone but not for me even tho i do the EXACT same thing as shown, same situation is going on here none of this is working at all, i see no difference and for some reason my script colours also changed despite me not changing them from the studio settings, idk whats going on

Have you tried all three methods? Including the last one? If you have already uninstalled Studio and reinstalled it, did you try removing the program files I mentioned? They are accessible with Win key + R, but read more about that before trying. As mentioned before, you can also try third party uninstallers (with appropriate precautions taken).

Another thing that could be messing with your settings are plugins. Do you have many plugins installed? Do you use any “suspicious” plugins from toolbox? If so, try removing them or at least disabling them and repeat the process above.