"Bad Allocation" and "cannot save" after test

bug

#1
  • Describe the bug:

Pressing Play or running any sort of game test, essentially you get an error that says Bad Allocation or I get this in the output after the test.

23:46:52.231 - Error saving file ‘C:\Users\broth\Desktop\qq.rbxl’ - Error in saving data to ‘C:\Users\broth\Desktop\qq.rbxl’.
23:46:52.231 -
23:46:52.232 - Please try again or save with a different file name.

Naturally I would attempt that and I would proceed to run into the same issue again and message in the output. It was honestly working perfectly previously but it doesn’t seem to matter what game, the results end the same with game test. Another source of the issue is moving a model file that I would own from my models folder into studio and the bad allocation occurs and you can’t save the game. (It also states it cannot auto save and requests if I wanna turn it off.)

  • How often does the bug happen:

Every time as of the last few days, since the previous studio update,

  • Where does the bug happen:

Anywhere in Studio in general, even on the basic baseplate.

  • Would a screenshot or video help describe it to someone?

image

  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke.

Last studio update.


#2

Do you have any aggressive AV software that may be disallowing studio file write access?


#3

I’ve seen this before and it was caused by something preventing Roblox from writing to disk. (Ie. permissions, antivirus, folder missing, other weird file system magic)


#4

That was honestly the first thing I looked into, unless Microsoft’s base antivirus program did so without knowledge, then no.
Since that’s the only thing I have currently on this PC.

image


#5

This bug is still active. I cannot place an extremely-huge-item-count model into ReplicatedStorage and when I try to it gives me this error:

image

Furthermore, Autosave errors saying “Cannot autosave, would you like to temporarily disable it?”

This happened in the middle of a Studio session and somewhat happened after I deleted and replaced the above model with an updated version of itself once every ~5-10 minutes.


#6

This happened to me just now, I made some changes to our game and I cannot save anything, it’s shouldn’t be outside software or hardware related at all because I’m on a ‘fresh’ roblox laptop.

Error saving is from me attempting to save my current copy, and bad allocation is me attempting to press play solo and attempting to publish.


#7

I’m bumping this as this issue needs attention. I run into this problem more than 5 times every day and it’s resulting in lost work. You cannot save or publish your place file. It’s getting pretty out of hand and is overly frustrating.
It also stops you from being able to play solo.


#8

I can get bad allocation errors but it is usually due to high RAM usage when testing. Maybe that has something to do with it as my smaller places don’t seem to get this error as often however I still occasionally get it even on smaller places.


#9

I’m experiencing the same issue and definitely needs attention. It has come to the point where I have 0 successful test sessions as studio throws a crashing error and dies. The place file is 19.7MB and never had this issue before. I even tried removing everything from the map, disabling PreloadAsync scripts, with still no success.

I occassionally get through the loading but will quickly receive a bunch of memory errors.

After a bunch of tests, I’ve found that the cause is mainly due to a massive amount of items (17000 objects) in ReplicatedStorage that cause the errors and crashes. This is where I store my assets, and I need them to be there.


#10

Pretty sure this is due to 32bit application being limited on memory, because “Bad allocation” means the program can’t allocate memory.

Hence:


#11

In one of my larger places I’ve started to get this error.
image
I only have this issue in one of my places. Is there any temporary fix?

image
I’ve also tried this, but no effect.

I also get this error about not being able to autosave.

EDIT: Sorry for the “bump” but it’s still an issue and relevant.


#12

I get the localization error in my console.


#13

I have that localization error too at many places , I think it’s because we didn’t upload a localization table. Don’t know why it’s getting overridden.


#14

I don’t think this is right. I’ve never uploaded a localization table in my whole life and I’ve never had this issue before. But I believe it’s due I have large amount of “smooth terrain” (Roblox terrain).

Here’s the error about not being able to autosave.
image

EDIT: after reading a lot different threads mentioning this error it seems like this is the issue. They’re all mentioning that they got a massive amount of terrain.


#15

I get that error from files with no terrain but many instances.