Being unable to pick up my dodgeball

Hello, this is my first post on the forum. but ill try my absolute best to explain, I’m currently making a competition game with a dodgeball game mode. And no matter what I tried, I can’t get the players to pick up the ball. I’ve tried to add a script to when the player touches it, it gets cloned to their backpack, and even looked it up on forum and other sites, as well as replacing the ball entirely. Still nothing. Can you help? Thank you.

1 Like

First off.
To get the player to pick it up what you would have to do is make it so once they touch, this being a server script.
Give them a dodgeball tool.

And that’s basically how you would make the whole thing.

If you dont understand/dont know how to I would recommend finding a tutorial

Second off.
I think this would be more of a scripting thing. So I would change the category to:


I wish you all the best on your journey!


1 Like

I will try this out, Thank you!
Edit: i forgot to mention that whenever i insert a tool it wont pick up, but if i use a tool from one of my other places, it picks up and i have no idea why so ill try that as well

1 Like

Turns out it didn’t work for some reason, I tried both and it will not work. And it doesn’t seem to have anything to do with the script(P.S im using the Roblox Battle Ball). The script I used for pick up is

function giveTool(part)
local player = game.Players:FindFirstChild(part.Parent.Name)
if player then
script.Parent.Handle.Parent = player.Backpack
--the script is inside the tool, not the handle 

To just pick up an item you don’t even need a script at all. If you create a Tool in the workspace, add a part(ball) as a child of the tool and then rename the ball from Part to Handle you can run the game and pick it up.

I have done that, but when i place the dodgeball script in the part, it wont pick up no matter what. I have even made a tool in a separate world that works and transported in the game. Still works, but when I place the scripts, that’s when it won’t work and will instead move the part, not pick it up.

Where does that Roblox Battle Ball come from? I don’t see it when I search the marketplace.

it comes from here: ROBLOX Battle [OPEN] - Roblox
its an old place from 2012 so im not even sure if most of the code is still working, but from what i tried, it does

I looked at the ball you are talking about. When they throw a ball they don’t throw a duplicate functional ball, they create a Part called Cannon Shot that they throw. It is not a tool and therefore you can’t pick it up and use it. You would need to rewrite their script to make it a throwable tool.

Thank you, I will try to fix this. Thank you so much!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.