Bevel Plugin (Working in 2021)

This plugin allows you to add bevels to a part along a certain axis. All you do is enter a scale amount (Size of bevel) and click one of the buttons corresponding to an axis. It even shows a preview of how much of the corners will be cut off. This creates bevels instantaneously and includes an undo button in case you aren’t satisfied with your result. Here is a video preview

and the link to the plugin


does this still work if you select multiple parts at once?

not yet but I will add that asap

I just updated it so it works with multiple parts. All you do is select multiple parts and use it how you normally would.

i keep getting this error

I’m 60% sure I fixed the error. Try using it again and let me know if it still doesn’t work.

I actually just figured out that it hasn’t been able to work for anyone at all except me. I just fixed this though. No wonder it has such little sales. To get it to work I believe you’ll need to uninstall and reinstall the plugin. This time it’s gonna ask for script injection which there’s no other way for me to get it to work without it as of right now. And if you or anyone else is concerned about viruses you can use it in a separate project and copy the parts over.

1 Like

It works great now! Updated it in studio it worked.

Worked for me as well! Thank you for this amazing plugin.

I watched the demo video, plugin looks great! Thanks for the contribution!

Might want to put the video directly into the post instead of a Drive link.

Awesome Idea! Good job, This will help me with a lot! Congrats


Stop putting your plugin’s GUI into StarterGui. It’s triggering Studio’s script injection permission which is a permission I should not need to grant to your plugin.

Luckily I’ve skimmed your source code and found nothing malicious, but if a plugin like yours ever asks for script injection perms, I’m going to delete it right away.


1 Like

Where else would I parent it other than StarterGUI?

After doing some research I found that it is better to parent it in CoreGui instead of StarterGui which I did. Hopefully, It should not ask you for script injection permissions anymore after you update. But just for future reference if you have a fix to an error please say it instead of just pointing the error out :slight_smile:


It should have been obvious to parent it to the CoreGui or to a DockWidget.