BindToClose 100% Infinite Yield


#41

The update is deployed around Tuesday evening and rolls out around Wednesday afternoon.


#42

Any news on the fix for this? Definitely past noon.


#43

Still not fixed :confused:


#44

Confirmed also not fixed, it’s been another week


#45

Still not fixed :confused:


#46

This still hasn’t been fixed as of the last update.


#47

Any updates on this? :confused:


#48

Same issue here, really annoying when i want to test in solo mode.


#49

Please tell me there is a fix coming out for this soon. It’s seriously slowing down development, I have to wait 30+ seconds each time I end a playsolo session when I’m quickly testing a change in my code.


#50

This is still a huge problem, testing safe data store code is made much more difficult and tedious through this.


#51

Really need this to be fixed asap. Are there any update or an ETA?


#52

I can reproduce this 100% of the time when using coroutine.yield. Here’s two examples. The first works fine, and the second causes it to hang:

-- Works fine:
game:BindToClose(function()
	wait(1)
end)
-- Will cause Studio to hang when leaving:
game:BindToClose(function()
	local thread = coroutine.running()
	coroutine.wrap(function()
		wait(1)
		coroutine.resume(thread)
	end)()
	coroutine.yield()
end)

My game framework utilizes coroutines within the BindToClose callback in order to execute and await the completion of any number of tasks.


#53

Any update? Almost two months since your post and this is still a live issue.


#54

We recently turned on a flag that fixes the original problem as reported.
Since then a separate (but related) issue has been reported relating to using coroutine.yield in BindToClose.

That is still an open issue, as I just heard about it days ago.

If you are still seeing a problem in BindToClose and you are NOT using coroutine.yield, please let me know.


#55

Bumping, as this is still an issue. Is there any update?


#56

Sorry, no. Spent some time on it and could not figure out what exactly the problem was. Will try to prioritize a revisit.