Blender exported models have "too many triangles"

So, I am trying to import Guns someone gave me from blender, I import them into blender and separate stuff like mags, stock, etc. and then export them.

Now I am having issues with importing it into roblox studio. Everytime I try to put it in a mesh, it always says “Your mesh has too many triangles! Limit is 10000. Your mesh has 12211”

I have tried doing almost everything. I even contacted the person who created the guns and he removed many unnecessary parts, and the error still says “Your mesh has too many triangles! Limit is 10000. Your mesh has 12211”.

Some help would be greatly appreciated!
Thank you

Did the person who gave you the guns use decimate to lower the number of tris?


Please provide an image of the Blender workspace. We can’t reasonably know what your issue is without seeing what’s going on.

I didn’t even notice that the limit is 10k and not 5k anymore… In any case, this issue needs to be directly solved in a 3D-modeling software. You need to reduce the triangles by yourself. Try ALT + J, decimate, manually remaking it. Splitting the mesh into managable parts.

Please refrain from suggesting people split their mesh to solve their issues. It’s bad practice and there’s usually a better solution, not to mention that without OP giving us an image of the Blender workspace, it might not even be the issue.

Regardless, please don’t suggest it as a solution in the majority of cases. Very few models used for Roblox require 10k+ tris, and if detail is a concern, use a texture.

I find that rather ignorant, if you’re eager on having a certain LOD exported to Roblox, there is no going around it.

Firstly, you would shade smooth and turn on auto smooth, then add a weighted normal modifier, and turn the weight all the way up. This will ensure that decimate would lower the triangle count and will not affect the mesh too much. As they said, use the decimate modifier and fiddle with it until its under 10000 faces.