Blender GFX hair broken

Hello so I am here about a problem I have had with one of my GFX. I want to find a way to fix this problem due to wanting to create for GFX so I can start doing it for other people. The issue I am having is when I render the image the hair of the rig/roblox user starts to fade away and just shows the bald head. It’s very strange due to I have already made one and it worked fine for me at the start but when I did another one I had this problem. Picture of the problem will be the first picture and the second one will be the GFX I made first (my first every one)* When it first stopped working like it should do when redering I retryed it on a different blender in case it was something I changed but it did not change any thing. I also tried to do it with the charter I did at the start but it was still having the same effect. If you could help me that would be great.


Broken one/the problem.

The one I did at the start that worked fine.

Might want to slap a denoise node and fix some texture issues however, to fix it, just go to the shading tab and click on the hair/any assets that are transparent like the ice cream.

Once you’ve done that, remove the alpha part that you see within the shading nodes.

1 Like

How do you put a denosie node on? Sorry I am quite new to blender.

Are you sure this is a Mesh issue?
It almost seems like you have a script in the game that’s changing the Transparency of your hair.
When you test it in Studio have a look in your character at the Hair mesh. Check the value of the Transparency of the Mesh.
If it’s anything other than 0 you have something else going on. Meshes don’t just change their Transparency.


Denoise node tutorial.
1 Like

As I did put in my post it’s in blender not in studio so this is not the problem I am sure. I also did not put any scripts into the game that I got the assets from.

This is just an issue with blender, the new updated version seems to mess with hair assets/assets from roblox and automatically attaches the transparency. A simple fix will just be to de-attach it in the shading tab.

Eevee doesn’t have this issue though because, well, logic :man_shrugging:, however eevee sacrifices details so cycles is recommended.

I bet this is why most people on youtube I watched had a older version of blender then the new updated one.

Please take a look at the youtube clip, Its a simple trick and it works 100% of the time. https://www.youtube.com/watch?v=GzJRVJEeyTE

2 Likes