[Blender] Mirror Modifier Not Working as Expected

I’m trying to get his object to mirror on the other side of the object on the back side. However, it does this weird thing where it’s clipping inside of it and makes almost a hollow shape.

Before Mirror Modifier:

After Mirror Modifier:

How would I go about adjusting / fixing this? If anyone could help, it would be greatly appreciated. Thanks!

Have you tried changing the axis?

image

The image shown is the axis I am looking for, it’s just that its in the wrong position.

Current Position:
image

Desired Position:
image

Select your mesh> ctrl+a> all transformations> then add you mirror modifier. Hope this helps! :grinning:

Also there are other options like flip and bisect try those as well

Definitely is closer to desired. Only problem is I just get this weird clipping where the other side is going slightly through. Any ideas on how I can fix this?


This doesn’t seem to affect my model much.

Can you send a screenshot of your mirror modifier settings?

Here are my current settings:
image

You can try enabling Clipping, tell me if that works.

Select the outskirts of the mesh, now press Shift+S, Cursor to Selected. And then go into object mode, look for the object button image (top left corner) → Set origin → Origin to 3D cursor and done(or you can right click the mesh in object mode and do the same).
Mirror modifier works base on the origin of an object. That’s why it happened

1 Like

Is now working flawlessly. Thank you!

1 Like