Blender model unable to import

  1. What do you want to achieve? Keep it simple and clear!

I’m trying to import one of my models I made in blender but it’s failing to import and I’m running out of reasons as to why it is

  1. What is the issue? Include screenshots / videos if possible!
    Both the import tool built into Studio and the plugin for blender aren’t exporting my mesh properly

    The above is me using the blender plugin, normally, when a model is missing, it means an empty object is there with no vertices, the solution is to delete it in blender and reimport. But no, this is not the case here.



The 2 screenshots above are using the import tool built into Roblox Studio, normally when you first open a mesh in it, the dimensions are set to studs and it’s expected to be set to infinite. Setting it to something else like cm should fix it but in my case it’s done nothing. But there isn’t anything to suggest why it should be doing this

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

I’ve tried the following:
Deleting empty objects in blender
Scaling it down in blender and reimporting into studio
applying any modifiers that are there (mirror, etc)
exporting with selected objects only
exporting with visible objects
using a different blend file
I’ve tried testing with a different model completely which at least has shown a preview as seen below, suggesting it’s the model itself but I can’t see why.
Exporting with the blender plugin
I’ve went into the import tool & scrolled through each mesh individually to check the triangle count, none of which are at 0

As well as searching on the devforum (the search is super unhelpful)
And I’ve asked on Hidden Devs (super super unhelpful) twice

After that, you should include more details if you have any.

The triangle count is roughly 30 thousand triangles split over 165 objects, which is still within the import limit of 200 objects.


Importing the meshes individually seems to work but I really do not want to do this unless I absolutely have to

Originally I thought it was the blender plugin having issues trying to sign me in but that was fixed with a reinstall with this issue persisting.

I really don’t know what else to do, this is my last resort

1 Like

Screenshot_4969

FOUND IT, use the asset manager to filter any meshes out that will catch you off guard

1 Like

Sorry this is off topic, it dang you got 30,573 polys in one model? That’s a ton bro.

Compared to other similar models, it’s tiny in comparison
Also I’m not doing it for making a game but rather for the sake of it so it doesn’t matter that much to me anymore.

1 Like