Blender rig exporter/animation importer

When it already says solo mode

After I Import a animation. I tried following youtube tutorial but didn’t seem help.

Is that rig inside a place that has team create enabled?

Yes, the game team create is enabled.

How would I make it so that the legs stay in the same place.

Now that theSkinned MeshParts are alive, will you update the plugin/addon @Den_S?


Apologies for the delay in reply, but that would be why, for some reason the plugin does not like team create, so you need a separate place where you import the animations

1 Like

It worked! I can’t say how much I thank you!

When I try importing an FBX animation (using Blender 2.79 and the version by @XAXA ) I get this error. Not really sure how to fix this, any ideas? Thanks!

Edit: Just installed version 2.82 with the recommended script, however getting the same error.

“Cannot map rig, the following bones are missing from the source rig: HumanoidRootPart, LowerTorso, UpperTorso, LeftUpperArm, LeftLowerArm, RightUpperArm, RightLowerArm, RightUpperLeg, RightLowerLeg, LeftUpperLeg, LeftLowerLeg.”

I understand that the animation I’m trying to import isn’t labelled according to Roblox rigs, but I thought this plugin should account for that? Not sure. Any help appreciated!

1 Like

you sure u didnt rotate the rig by accident
and ur sure ur using the 2.8 version of the plugin

Yes, I’m sure.

The problem seems to be that my FBX animation contains more limbs than a typical Roblox rig, so I’m going to need to figure out how to make them compatible.
If anyone knows anything about this, please get in touch!

1 Like

what i usually do is check the rig on the roblox animator first incase its rigged wrong cuz it does sometimes say which bones are rigged wrong

if it still refuses to import i just take a new r15 or r6 rig and rerig the stuff back

I don’t know if it’s the place I’m using but I’ve come across a rather weird bug.

Anytime I open the roblox plugin all my dummies start doing this spin dance apart from the one I selected and a card model in my game clones itself into the workspace and when I close the plugin they stop but don’t go back to their original position.

just save ur last instance before export then reopen the place export the rig and then press dont save u would then have a non dero place anymore

Importing old r15, new r15, rig built r15, r6 or anything doesn’t work. it just says some error in line 480. Using blender 2.80 and the recommended script for it. I don’t get why

Currently I am trying to create IK constraints for my character but I don’t know how to.

I build the rig.


Then I select all the bones and create the IK constraints.

Then I export it as an FBX file.


And then I import it.


But when I try to animate it, it just does this and no IK button is there

I might be doing something very wrong or this may not be the right plugin for this. Please let me know!

Also, am I supposed to make a post asking this here or somewhere else?

Oh god by looking at what you did with the ik makes me hurt inside

do not make everything IK constraint only apply IK constraints where u bend smth flr example

upper arm and lower arm were the “elbow” is

the same where the knee is

also u have to animate it inside blender since u can export animations later on

im an idiot

thanks though lol, so there is no way to animate with roblox?

well there is a way to animate it in roblox

Either the vanilla roblox studio animator or Moon suite

1 Like

Hello, i’m not sure whether or not i’m understanding this wrong, but can roblox animations be exported to blender? Or can we only import from blender to roblox?