Blender UV Texture not showing up

Hey guys, i recently tried to do uv map texturing on blender, and i added it on roblox and the textures seems fine before but later on, When i added the mesh in studio, The textures won’t show up. How can i fix this?

I’m new to this stuff so i need your help guys

Did you save your texture image?

1 Like

Yeah i saved the image for the texture

You’re going to need to upload it

Roblox site>Create>Decals>Choose the texture file>Upload

Once it uploads, copy the link address of the texture you just uploaded and paste it in the mesh’s TextureID in Properties

1 Like

Oh ok, you can’t import the mesh with the texture on it?

No, the textures will need to be saved and exported separately

1 Like

Oh Alright, Thanks for the help!

If it has been solved, I suggest you to put the answer (comment) on solved.
I came to answer too but oh well


Well its kinda broken because i thought u can Import a mesh with textures on it and i did it before but now its not working

So i got this problem many times you can import your model to roblox studio with his texture But it wont work sometimes

1 Like

So how do you make it work everytime because its frustrating me

I Think its studio bug Save your texture then import it to baseplate but make sure the meshpart isnt mesh already if it wont work the solution is just import the texture as decal

I Tried uploading the textures in the roblox page but when i added it to the mesh, the texture is not properly located

Did you add the texture id in your meshpart’s decal?

yeah, I did place it in the correct area-

In Meshpart’s texture area if yes i dont have any solution on how to do it maybe try again in blender

1 Like

I’ll try to find a way to fix it, Thanks for the help anyways

…No Problem Good Luck!..

Oh and is it alright to talk on discord dms? i have smth to ask about this problem

Discord: Pansorial_YT#1438
if it will not work you can contect me on devforum too