Block Users from Messaging you on Forum

As a Roblox developer, it is currently too hard to manage my developer forum DMs because of spammers, scammers, you name all the reason. This happens to me a bit, and sometimes I even get troll messages.

If Roblox is able to address this issue, it would improve my experience using the forum because it would help me make my developer forum inbox much cleaner.

2 Likes

If you want to disable them globally (except forum staff), then just disable the Allow other users to send me personal messages setting in your preferences. If you want to do it per user, then just mute/ignore them:
image

4 Likes

Closest we have to it, but not an actual feature.

2 Likes

That effectively “Block[s] Users from Messaging you on Forum” though. The latter option also hides their messages, collapsing them in a manner similar to Discord. Although, spamming is against the rules, so if someone is breaking the rules in DM, just flag the DM and moderators will be able to investigate.

But that way you will block everyone’s messages

Not if you ignore users individually. Ignoring is actually better than blocking, because the other party won’t be aware that they’re blocked.

Compare it with Discord. Once they know they’re blocked, they’ll try to bypass it with ALTs & etc. If you choose to mute them instead, they will eventually give up most of the time.

2 Likes

I think you confused OP because the screenshot isn’t in English.

@2xy0x the features that @incapaz listed do exactly what you want: if you ignore a person, they are unable to DM or otherwise notify you.

1 Like

That feature is not even available for me.
image

You should support this feature request then:

Although since that topic was made, a min_trust_level_to_allow_ignore setting has been introduced, so it’s just a matter of an admin changing the value to something lower, as mentioned in that topic this was previously hard coded to TL2+

3 Likes

Thanks for making this post and thanks @uep for mentioning that setting. I’ve gone ahead and set it to a lower trust level.

Can you try if you can ignore users now?

7 Likes

image

Works for me.