Body Velocity not working on welded objects

Pretty much exactly as the title says, I want to have multiple objects that are connected to the main one be able to move together using body velocity, But I’ve encountered 2 issues with this. The first is that whenever I scale up a part to a large size, body velocity stops working, or at least takes a massive number to get, (above 10000000 force) I’ve tried decreasing the density and making the mesh-part massless, but the issue persists, I cannot get the part to move upwards, moving it side to side works, but the part will only roll in one direction, no matter the direction I put. The Second issue I’m encountering is that if I weld parts together using weld constraints, the body forces immediately stop working and the part becomes stuck in place. I’ve also tried using weld scripts, regular welds, but none of these same to change the issue, I’ve double checked to make sure no parts are anchored as well, and the part will fall to the ground and can be pushed, but can only be pushed around its axis that’s stuck in the ground. What am I doing wrong?

1 Like

Make sure any objects have the Anchored properly set to false, and try changing the BodyVelocity’s MaxForce to math.huge inside a script?

Have you had a look at the Anti gravity script section of the BodyForce | Roblox Creator Documentation page?

You may also be running into issues with the NetworkOwnership of the Parts involved.

It looks like it has something to do with the welding, unwelded parts are affected by the anti gravity script that you sent, but the moment i weld them, it gets driven into the ground and stays there.

Are all the Parts that get welded Massless or not?


Just checked now, a small part near the tail was causing the tail issue, but i’m still having issues with using a body force/velocity to get it in the air I used a body force script and multiplied the force by 100 million, and it seems to work now, thank you for helping me out!

1 Like