Boxy shadow edges in character render

I was testing out a character render in Blender the other day and the “finished product,” (more accurately, what I could get out of it), had some boxy indications around the edge of the head, as seen in the screenshot below:

If you look close enough, you can see where the edges sharpen off. I used to use Blender for years and, being a fan of realistic shadows, this was never the truly desired result, so I moved onto Cinema 4D. Oddly enough, the boxy parts of the shadow never transferred over to that program.

I went into Photoshop and sloppily fixed the areas to represent the coverage I’m looking to create:

I couldn’t find anything on the DevForum that had anything to do with this. Subdividing the surface of the head somewhat helped, but left a black streak across the head which was similarly as undesirable.

Without having to touch up too much in a photo editing software, is there a way I can get a smoother and cleaner result like what is pictured above?

Edit: To avoid confusion, the second image does look different in brightness and softness because I did do some edits to the original, raw image before making the fix with the shadows on the head.

I’ve had the same problem for all the 3+ years I’ve been using blender, and it is a bit annoying. Luckily, there’s two ways to fix it.

In post-render

You can smudge away the sharp outlines of the shadows so that they’re smoother, and that’s what I normally do since it doesn’t take too long and isn’t too destructive to the render.

In blender

  1. Go into edit mode after selecting the head. Select every vertex of the mesh, then press W > remove doubles.
  2. In the data menu on the right, uncheck auto smooth.
  3. While in edit mode and ensuring every vertex is selected, press W > subdivide smooth twice (or more if you want it even smoother, but usually there’s no need).

    This should fix the problem.

I tried it myself, and this is how it turned out:



What @RipperGFX said is mostly right. Low-poly meshes have rather sharp edges, so it’s quite noticable when the sun’s light rays cannot reach part of the geometry. You can smooth out the transition by subdividing the model.

However, i would recommend taking a different approach on this step.

Do not subdivide your model in edit mode if your goal is to give the entire model more polys. Instead, apply a subsurf modifier. The reason for that is because it’s non-destructive and can be toggled.

Any changes you make in edit mode are destructive and cannot be undone easily, hence you should use modifiers whenever possible.


In addition to that, you may want convert all the triangles into quads by pressing Alt+J in edit mode, otherwise the shading gets a bit messy. Example below.


Thank you both! Everything explained seems to have worked.