Breakpoints do not work with modules on the client with Intuitive Debugger beta feature

Reproduction Steps

1. Go to Roblox Studio.
2. Enable Intuitive Debugger in beta features
3. Add a module script to the startergui or replicated storage.
4. Add breakpoints in it.
5. Run it throught local script while testing in studio.

Expected Behavior

I expect breakpoints to work like server scripts, local scripts and like module scripts that are on the server side. This used to work but is broken since the last breakpoints overhaul.

Actual Behavior

Breakpoints do not work with modules on the client when testing in studio.

Additional Information
This bug appears to happen only when Intuitive Debugger is enabled in studio.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date Last Experienced: 2022-07-04 00:07:00 (+02:00)

1 Like

This is not happening to me.
It’s working just fine. Maybe you need to add a wait statement in your script like I did.

It’ still broken. Are you sure that you’re using a local script and that the module is on the client in the startergui or replicated storage? As this issue only happens when the module script is on the client, server works fine.

It also used to work before on the same module scripts that aren’t modified ever since. But its broken since they updated breakpoints with adding the “Disable Breakpoint” option.

This issue happens to any game in studio and not only to me, but all my friends are having this issue.

I did not try that yet, I will now.

I’ve been with Roblox since 2018, you don’t need to remind me.

Is that a beta feature? I normally do not enable those.

I tested it again, this time with the ModuleScript inside of ReplicatedStorage. I am not able to reproduce this problem. Both of the scripts are selected here:

I looked in the beta features, it was not there. May I see your LocalScript and ModuleScript that you are using?

1 Like

Thanks, it’s a Roblox Beta feature that’s breaking it. I didn’t realize it was enabled because it automaticly enables new beta features. The beta feature “Intuitive Debugger” was the cause. Now that the beta feature is disabled it works again. That’s probally why it worked for you and not for me.

Edit: Updated the title knowing the cause now

1 Like

Yes, for me having the beta activated made it so couldn’t even trigger the breakpoints in any file. It basically deactivated debugging for me and this is the only post that I found that blamed it on them and it’s the actual problem! Thanks a lot! This is a serious bug.

1 Like

Sorry for the super late reply. We’ll look into this now.

1 Like

Just checking in. Are you still running into this issue?

Can confirm it’s solved on module scripts on the client as of now.