[BUG] Free Model Thumbnail isn't Working

I am making a thumbnail for a free snowman model, but when I copy the Camera and rename it ThumbnailCamera it doesn’t work. I’ve done this before and it worked in the past, and I’ve tried renaming it and copying the camera again but it doesn’t work.


Can you give us more details about the problem? Is it when you try to upload the model?

When I press Save to Roblox to make it a free model, the model image on the left is incorrect.

1 Like

Here you go maybe this will help

I don’t create free models that often, so I don’t really want a plugin (I already have the full GUI setup too). It should be doable with studio itself as it always has been for others, if the plugin can do it, I should be able to as well.
Here’s even a reply from that post.

Another Screenshot of Problem

Have you done this? Directly off of Fandom,

  • Users can make a thumbnail for a free model by copying the camera, pasting it to a model then changing the name of the camera in the model to “ThumbnailCamera”.

If so then I unfortunately cannot help you with your problem :confused: Best of luck finding the answer to your predicament :smiley:

1 Like

Okay, I found out it’s just a bug, it actually does work but it doesn’t appear as the thumbnail until it’s posted and goes through moderation…

1 Like

Yeah, I had a feeling it was a bug, because mine was working perfectly fine!