(BUG) When model with scripts is duplicated, only the original model is fully functional

Basically, I’m creating this combat game involving enemies that can fire at players and create shields. I’m planning on adding multiple of the same enemies, but when I duplicate the enemy, only the original enemy is fully functional (creates shields, fires at players) while the other duplicates just fire without creating any shields. I tried searching other similar forums for the same issue, but so far I haven’t had any luck finding results that actually worked for me. Here’s the video as an example (Left is original, right is duplicate) Dropbox - 2023-06-20 19-32-20.mp4 - Simplify your life

I don’t think anyone can help unless you give us the scripts in question.

Also stop making multiple posts about the same thing. It takes time to answer.

Put the scripts in the enemies and not making it one script only, if that’s what you’re doing. Make sure that the scripts are also enabled once the enemies spawn.