Button Spacing issue in Screen Gui!

I’m making a game and there is teleportation in my game, teleporting is done with buttons. I had the buttons adjusted regularly but when I played the game I found that there was a big problem. You can check before the problem is solved. Address: Adventure Box - Roblox
Although the game includes MM2 maps, the game’s own maps will be released very soon. The aim of the game is to be able to fight wherever you want. Including MM2 maps. I went too far off topic.
The texts in the photos may seem meaningless because they are in Turkish. There is also an English version of the game. The 1st photo is while game making.
The second photo is during the game.


You need to explain what the problem is!

Try to include only what is necessary. You have kept something unrelated, but haven’t even fully explained the problem.

Also, it has only been 18 hours. Usually, it can take a few days for these types of posts to get responses.

You shouldn’t really be telling people you’ve stolen the maps of an extremely popular game to use in your own game. Just make your own.


Hello, Thank you for your opinions. I’ve already given up making such a game, but my problem is still not solved. The problem will be that there is no space between the buttons while doing it and there is no problem when you try to test the game in roblox studio. The problem is that when I enter it in roblox and go full screen, a noticeable gap appears. ScreenGui’s IgnoreGuilnset Feature is On.


You can make a separate frame for the buttons and use a UIGridLayout and set it’s Padding property to 0,0,0,0.

ButtonSpacingExample.rbxl (51.4 KB)


I think it makes more sense to create a separate frame for the buttons. Does this work? I will try.


Did it solve the problem? Is the spacing gone?


Use scale instead of offset.

Why do you guys never know anything about UI these days? I’ve worked with “ui designers” in the past, and they drag the UI around using the studio UI editor (which is the worst practice).

Hi Everyone, I’m sorry but the problem unexpectedly resolved itself. Actually, it’s not completely solved by itself, I opened a new game, it works in a new game, but the old game still has this problem. The old game wasn’t very advanced anyway. Thank you for trying to be helpful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.