ButtonR1 not binding properly on Xbox

In my Xbox game, it’s only possible to ever have one weapon, so I binded over the default equip controls. ButtonL1 is used to equip a weapon, and ButtonR1 is to activate an ability. From what I’m seeing/hearing, the ButtonR1 is equipping the weapon which I’m assuming is from the default controls, but this shouldn’t be happening because I binded over it right?

I understand that this might just be an error on my end but when I use Control+Shift+F I can see that nothing else is binding ButtonR1. This is a big deal for me because people pay a lot of robux to access some of those abilities and they aren’t working.

2 Likes

I believe this is the Backpack CoreScript. My game is having the same issue.

1 Like

If you disable the Backpack the key gets released.

I did disable it though

Try disabling the backpack and then waiting a few moments; chances are if you’re running it in a StarterPlayer script, it’s running before the backpack actually runs.

Hi really quick question how come whenever you bind an Xbox control to CAS it fires both when the button goes down and when the button goes up? How do you make it not do that

It fires whenever an input occurs with that data; you can check data.UserInputState and data.UserInputType to check press/depress state.

Is there any major positive to using CAS over UIS other than binding multiple layers onto a single key? Because UIS seems a lot more flexible.

Binding the layers is the point. The best practice for control design is to have standard buttons such as ButtonB to go back or close a menu or ButtonA to equip/select/buy/etc. If you open a menu within a menu, ButtonB should close the first menu then the second. Also you can bind blank functions over menus that shouldn’t be opened. For example, I was playing Miner’s Haven and I opened the shop. I tried to use DPad to navigate it and it started opening random menus which is bad design.

Nope, it’s in the PlayerGui. Run right at the beginning of a localscript. Then the ButtonR1 ability is binded, then a while later the weapon is added to the backpack.

I think using the DPad to navigate is bad design. My shop gui clearly demonstrates that the DPad is used to switch categories while you use the thumbstick to navigate. I don’t know any major game titles that have you navigate menus using the DPad instead of using the thumbstick.

I’m in a Miner’s Haven server right now and DPad is used for: Help, Activate Ore Pulsar, Signal remote Mines, Withdraw All items, and they can all be pressed while the Shop is open.

Also, using DPad to switch shop tabs also doesn’t follow standard Xbox control design. It should always be the bumpers.

I didn’t say instead. Practically every game uses BOTH. You can navigate the ROBLOX app the entire Xbox dashboard with the DPad, as well as the default CoreScript selection thing. So I guess by saying it’s bad design, you’re really arguing with Microsoft/ROBLOX/etc. When I said ‘bad design’ I meant ‘doesn’t follow Microsoft standards for Xbox controls’. Why would it even be bad design? Navigating a 2D grid doesn’t need diagonal inputs, and it doesn’t need ‘in between’ inputs that an analog stick has. One press right = one navigation right, simple and accurate.

My bad, I swapped out DPad in the shop for bumpers a long time ago. I’ve personally never used DPad for navigation and find it very cumbersome when games offer only it. I’ve never received any complaints over my custom inventory navigation which only uses the left thumbstick. I stand by my argument that using DPad to navigate is bad design. The Xbox One isn’t some pillar of proper design to base everything off. It’s horrible and unintuitive menu is arguably one of the reasons it lost to PS4.

It’s not a matter of what’s “needed.” It’s cumbersome and annoying to use the dpad to navigate on the player’s side because the dpad on the Xbox One controller isn’t nearly as easy to reach as the thumbstick and the player doesn’t have to move either of their thumbs because they will already be on the thumbsticks.

Well, it’s not a big deal. I play Miner’s Haven myself and I got frustrated by it, but I never messaged you either, so just because you don’t receive complaints doesn’t mean it’s perfect. You asked what the benefit to CAS was; the benefit is simply the ability to easily follow standard control rules.

Many - people - disagree - with you including the people who work at Microsoft who are experts in the field. Those links are what I got when I searched “PS4 dpad menu”.

No, but your game is on their platform. The best practice is to follow the design rules of the system you’re on so people don’t have to get used to new things. The best controls are the ones that can be figured out through intuition, and conforming to the rules of the platform easily allow for that. This is a basic principle of game design. Also, you can use the DPad to navigate the PS4 menu as well… This isn’t something that Microsoft invented.

I think you’re overestimating how much of movement you have to make to reach the DPad… you have to move your thumb one inch. Yeah, very cumbersome. And it’s not like you have to force a user to use a DPad either! You’re still not understanding that the best practice is to just allow both so players can use whatever they’re comfortable with. How can you even argue that, if someone uses a method for menu navigation that LITERALLY EVERYTHING ELSE USES, they should be suddenly be withdrawing all their items!? That’s a good design choice to you??

I recently changed how the LB and RB buttons bind. Has this recently started or has it been around for a while? Also a repro place would be nice.

Recently started.

Repro is simple;

  1. Disable backpack
  2. Bind over ButtonR1
  3. Insert tool in backpack
  4. Press ButtonR1, your bind won’t happen, your tool will be equipped.

If this repro doesn’t work, I’ll take another look at my code and get back to you.

1 Like

I figured out what was wrong. It’s rebinding the core actions if a tool gets added to your backpack, even if the backpack is disabled. We’re pretty certain it’s a bug and not intentional.

1 Like

Thank you, the sooner this is fixed the better, people are spending money up to $10 for abilities in my game and they’re finding out they can’t even use it.

A temporary fix you can do in the mean time is re-disabling the backpack every time you add a tool to the backpack or character. This redoes the check if it’s disabled and unbinds the core actions.

Well, I can do that, but I can’t shutdown the servers, so thousands of players will still be playing with this issue for a while.