Cage deformer hidden surface removal is removing visible surfaces

The cage deformer is removing visible surfaces of my mesh with no way to disable/modify the hidden surface removal feature (to my knowledge).

With hidden surface removal:


Without hidden surface removal:


A private message is associated with this bug report.

Issue Area: Engine
Issue Type: Visual
Impact: High
Frequency: Constantly
Date First Experienced: 2023-08-30T21:00:00Z
Date Last Experienced: 2023-08-30T21:00:00Z


We’ve filed a ticket into our internal database for this issue, and will come back as soon as we have updates!

Thanks for flagging!



We’ve taken a look at the RBXM file and the FBX file, but were unable to reproduce the bug.

We did notice one thing though. The Outer Cage of the body (which is the Inner Cage of the clothing) is essentially a copy of the body geometry plus a few extra faces. We suspect that this is causing HSR issues. Since we’re not able to repro the issue, can we ask you to try this? make the Outer Cage of the body (and the Inner Cages of the Clothing, ever so slightly bigger than the body geometry and see if it fixes the issue? Please let us know the results. Thanks!


Hello, sorry for the delay! After adjusting the inner cage to sit on the outside of the body, no HSR problems were resolved. Only noticeable difference is a very minor clipping problem in the chest area.
I then went on to remove excess geometry (Only faces deleted, as I am aware merging faces would cause UV distortion and ruining the skinning transfer) from the inner cages to see if that was the issue with HSR but that only made the geometry on the pants in particular extremely distorted and made the jacket overextend it’s skinning to the left arm.

FBX files of both tests and RBXM file of the models imported

Left is the resized inner cage. Right is the excess geometry removed.


Are there any updates on this, it’s been 2 weeks since the last response and this issue is still occurring with no way (known to us) to fix it. It’s really frustrating to put time into these rigs and then have these big aesthetic ruining issues that we have no way to address.

Hi Axen, thanks for your patience. I *think I fixed it, but there’s no way for me to test it since your characters and your clothes are both not skinned in the rbxm and fbx files you uploaded.

As you can see, the one of the left is the one I fixed, and it looks correct.

I fixed it by converting the clothing into Accessories before putting them under the Character’s hierarchy.

Please give that a try and let me know if that works for you. Thanks! If it doesn’t, please send me an FBX file where the character and the clothing are skinned, and I can try someting else.

1 Like

We’re relying on auto skinning to handle the deformation which is why it’s missing, I will give your solution a try. Thanks for the help!

Hello! We tried converting the clothes to be accessories but this just removes the auto skinning so it no longer deforms with the body.

Do you think there is anyway to just be able to disable the hidden surface removal? We don’t benefit much from it anyways as the rest of the body itself is relatively low poly but it’s causing us some major headaches.

Conversion to Accessory should not remove Autoskinning.

You need to make sure you’re converting them into Layered Clothing Accessories, rather than Legacy / Rigid accessories.