Calling :MakeJoints() isn't working

I didn’t know what topic to put this in because it isn’t technically scripting but it does involve some physics (I think) let me know if i’m wrong :smile:

Recently I created a topic, asking for help on how to clone a vehicle from ServerStorage and get it to work. The solution was to call :MakeJoints on the model.

Original post

Hinges refusing to be detected

This all worked until I moved one model from the ServerStorage to move some parts around like the vehicle seat’s position and the seat model position. Once I put it back into ServerStorage and tested the game to see if the player was now sitting properly on the seat, the vehicle didn’t fall apart, but it wouldn’t move either.

Is there some sort of procedure that I have to follow when editing vehicles to get the seat to register the vehicle?

Any replies appreciated :smile:

Have you accidentally anchored a part within the model?



Yeah, check if any parts are anchored. If they’re not, make sure that the model isn’t creating joints with other parts (such as the surface it’s on).

Oops… replied to the wrong person. @RedDuck765

Nothing inside of the model is anchored or creating joints.

I should probably add that the vehicle freely moves if I walk into the back of it, I feel like something is wrong with the seat rather than the joints… I don’t really have enough experience in the matter to even start to try and explain though.

Please keep in mind that :MakeJoints() only works with parts that have surfaces that can make can a make joint. So if every part’s surface is Smooth, or surfaces that cannot create a joint with eachother. Zero joints will be created.

Sorry I should rephrase. What I meant by it wasn’t creating joints is that as I was building it, no strong joints were being created, stopping the wheels from spinning.

Is it possible its something to do with joints being automatically created as mentioned in

No as mentioned above:

OK. So did you happen to save the model to a file (rxbm) before changing it? If so does it work when copied back in?
If not do you have a backup of previous version and does that still work?
I am asking as you wanted to know about a process to do the update.
In my case I have always made a copy of the current setup before doing any changes.
If no backup can you save to file and try importing it again.
I asking this as I have found on a number of occasions that something is not quite right and saving/importing resolved the issue. In most cases I never did found out what the cause was. I was too happy that it had worked.

No I was testing moving things around with in the place file

Yes, one I did not change at all

I will try and create a new version of the backup, after having created another backup, for now, I will mark this as the solution

MakeJoints can’t be called on models in ServerStorage. Have you read the documentation first or does none of this quell your issue?

You could use attachments as well if joints have been giving you grief.

I’m really sorry I seem to have phrased this really badly. :MakeJoints() was being called after the model was cloned to the workspace.

Thanks for the documentation though. :smile:

1 Like

Can you provide a repro? I can’t reproduce this

1 Like

I can do but currently the devforum has logged me out and is crashing on pc. Will update the post when it works