Calling with SocialService doesn't work outside of Roblox Connect

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I am trying to add calling through SocialService into my game
  2. What is the issue? Include screenshots / videos if possible!
    When trying to call someone through the phonebook, I get a popup that says “Oh No! Try again later”
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I tried some solutions which can be found at the bottom of the post, but nothing worked. I found documentation on the developer hub that had a code snippet with a typo, which is what I’m using right now.

This is the script

local Players = game:GetService("Players")
local SocialService = game:GetService("SocialService")

local player = Players.LocalPlayer
local button = script.Parent
button.Active = false

-- Function to check whether the player can send a call invite
local function CanSendCallingInvite(sendingPlayer)
	local success, canSend = pcall(function()
		return SocialService:CanSendCallInviteAsync(sendingPlayer)
	return success and canSend

local canCall = CanSendCallingInvite(player)
if canCall then
	button.Active = true
		SocialService:PromptPhoneBook(player, "")

When I press the button ingame, this shows up:
I enabled voice chat, cameras, and HTTP requests for my game, and it is in R15, but it still shows this message. I personally only have voice chat enabled, but I can still make calls in Roblox Connect, despite not having a camera


Experiencing the exact same issue.

Decided to bump because it’s still happening

Linked to this bug report

1 Like

I think the problem I’m facing is different, since my game is more than a week old with voice chat enabled, and it shows a different error message. There is a chance that they’re both connected bugs though

Better to merge it to one place so its easier for Roblox engineers to sort through I guess.

Seems like a good idea. How do I merge my post with someone else’s?

I assume only forum staff can do that, I guess bump the one I linked since it’s already in bug reports?

Hi Bean!

From looking at the code snippet it looks like you’re missing the implementation of SocialService.OnCallInviteInvoked

In your implementation, you’ll need to return a table with the PlaceId of your target place as well as the associated ReservedServerAccessCode

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.