Camera is Acting Up (Magnifying Kind of Look)

I was just using animation editor Roblox Studio. However, after I closed it, the Camera started acting extremely weird. It started making everything look kind of like how something would look through a magnifying glass. Here are some pictures:

Has anyone else encountered this? How would I fix it?

This might be your camera FOV (Field of View) or just some really weird glitch. I suggest checking the properties for game.Workspace.Camera and checking any active plugins that might be causing this.


This is a bug in studio at the moment I believe.

To fix this go into workspace and go into the properties of Camera. Change the field of view to 70, which is the default roblox FOV


I just tried that, but all it just adjusted how much I could see on the screen.While testing I noticed that maybe the camera is off center. The sensitivity is extremely high and doesn’t rotate like it usually does. I went into a different game i created and the camera was working fine there.

OI realized what is wrong. In the camera properties, the Camera Subject is set to the Right Upper Arm of a Dummy. However, when I try to remove it, it doesn’t work. I clicked the red X next to the property, but nothing happens and the Camera Subject is still RightUpperArm. Does anyone know how to fix this? In a different game I have, the Camera Subject Property is blank.

I don’t think the problem was because of the animation editor, this has been happening to me and a couple friends recently too. It started after the most recent studio update.

I don’t know what causes it, but I wasn’t use a plugin or anything like that. It randomly happened when i switched from the script editor back into the actual place.

When someone figures out exactly what is causing it, they should probably make a bug report for this

1 Like

I realized that this was happening because of the CameraSubject Property of the Camera. It is usually blank, but I found that the Camera Subject for this peticular game had somehow been set to the RightUpperArm of a dummy. The problem is, I can’t remove it even though I clicked the X. Select your camera in studio and check its Camera Subject Property. (Also, I am currently just a member and I don’t think I can post bug reports yet.)

I somehow managed to fix it. Simply just select the CameraSubject Property, and hit delete. That should fix it :]

This issue could be a plugin that is affecting the camera, try looking through your plugins.

Just realized that you fixed it.