Camera not going back to player when it's custom

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!

    I want to make the camera go back to the player after it switches to custom. PlayerAutoLoads is off so it changes the camera after the player is loaded

  2. What is the issue? Include screenshots / videos if possible!
    The camera mode is custom but the camera is not where it should be, facing the player

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

    I tried looking through the internet but I couldn’t find a solution that worked

		local newcam = game.Workspace.CurrentCamera
		newcam.CameraSubject = 

Custom is not the default camera.
Fixed is, if that is what your looking for.

Ok, I’ll see if that will work

1 Like

I don’t think it works. It doesn’t focus on the player entirely

The humanoid have not loaded yet, use WaitForChild() instead of FindFirstChild().

That doesn’t work either :pensive:

What is your camera script? Is there any errors?

There are no errors. I changed it from last time but basically this is my local script (the camera script)

    local hum = game:GetService("Players").LocalPlayer.Character:WaitForChild("Humanoid")
	camera.CameraType = Enum.CameraType.Custom
	camera.CameraSubject = hum

(In another script I change the value of the variable “value”)

And in the server script it just has a plr:LoadCharacter

All the prints work and so does changing the camera but the camera itself doesn’t go to the player. I tried in another place and it worked perfectly fine so I don’t know why it doesn’t work here.

For the player’s character do:

local plr = game.Players.LocalPlayer
local char = plr.Character or plr.CharacterAdded:Wait()

Your character may not have fully loaded.

Ok I’ll try that and I’ll probably copy the code from my other place that worked

It didn’t work. But I will try a few different things lol

Ngl I think this is a roblox studio bug because I changed it to custom and changing the Cframe of the camera still worked

Ok I fixed it, I don’t know how, but I deleted a script from one and put it inside another and it seems to have worked. Thanks for all the help!