Can anyone help me to smooth a model out more efficiently? (Blender)

So, most of the models in-game I have are really low-poly. I’m fine with it for the most part. However, I want it to be more smooth without lagging the game. OR should I keep this low-poly look for my game? I’m kind of hovering around an idea. Any thoughts?

Here’s the low-poly unsmoothed model.

Here’s the same model with the “autosmooth” feature within Blender.


Right click on the model and click shade smooth. Add an edge split modifier. Change the Edge Angle until you get a result you like. Alternatively, you can go into edit mode and in edge mode you can select edges to mark sharp by right clicking on them. You still need the edge split modifier though.


Personally, I use bevels to make the end of the helmet rounder, just to keep the low-poly style.


Myself would use Auto Smooth alongside the Smooth Shader, it probably won’t be the best for you as there are also Edge Splits and making Edge Creases that will keep the smooth outline with the sharper edges that you choose.

You can find a full tutorial that covers the basis of sharpening edges here.


Another way of smoothing is by merging vertices. You can do this by going into edit mode, select the Vertex tab, and go down to Merge Vertices, select the ‘By Distance’ option. Once you have done that make sure to clear the Custom Split Normals Data. It should look more smooth after this.



This looks like it can be caused by bad topology. This can happen if you used Boolean to create the shape in the helmet. If that is the case, then there really isn’t much you can do apart from cleaning up the mesh using the knife tool, merging vertices and making sure there are no doubles. If that isn’t the case however, I highly suggest that you do not use edge split to fix your issues, it creates a lot more unnecessary geometry, ngons and doubles. Instead use auto smooth and choose which edges to make sharp if it’s not already calculated for you, and always make sure you remove doubles (merge vertexes as shown by others above)

1 Like

Add bevel first and set segments to 2 amount of bevel is 0.5 > and come profile tab of bevel set shape to 1000
Add Subdivision Surface second and set level of Subdivision Surface to 3, render to 2 (default)


1 Like