Can not change price of existing t-shirt in safari, because the text box doesn't show up

Today, I wanted to change the price of a donation t-shirt in my group, so I went to the shirt’s page, and clicked the three dots in the top right and then “Configure”. But, when I got to the “Configure T-Shirt” page, I couldn’t find where to change the price, or to put the shirt on/offsale. From what I remember, there is supposed to be a menu on the left, which you can click to be brought to the sales page, but for some reason it’s gone away. I tried to see if it would show up on another asset, a normal shirt, but it isn’t there either.

This is possibly a safari bug, so if someone running Google Chrome could check if this is the same for them, that’d be appreciated.

Device Info:

  • User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0 Safari/605.1.15
  • Platform Type: Mac
  • Device Type: Computer
1 Like

Looks fine on Google Chrome to me. Could be a Safari bug or something with browser extensions.

EDIT: I do have premium, so as Schedency mentioned below it is probably because you don’t have premium.

5 Likes

I can confirm that this is also happening with the latest version of Google Chrome. Cannot put things on-sale or off-sale.

Additionally, it may be because I don’t have a Roblox Premium membership.

3 Likes

I had that bug yestorday I just refreshed page sometimes and then it worked other time if not I waited some time and then it was there (I use edge)

This is a group item though, and it is already onsale. Additionally, I’m able to make developer products and gamepasses in the group.

This is still an issue me and my friend are having.


(the account in this photo has premium):

My own screenshot:

I am also experiencing this issue.

I am trying to donate to a group I own, and upon trying to change the t-shirt’s price, I saw that I couldn’t.

I am using Opera GX on a Windows 10 computer.

I am also having this problem. I don’t have premium anymore. Maybe that’s the problem?

Sadly, I think this is the cause of this ‘bug’. It’s actually a feature. Non-premium members cannot edit asset prices, which is outrageous if we’re going to consider that people who own the group that houses those assets can’t even edit them if they’re not premium.

4 Likes