Cancollide=false but Meshpart still collides

@FrendsDev and @oscoolerreborn please do not suggest code to fix these problems. The OP clearly stated multiple times that collisions are already false.

Your posts aren’t helpful.

@SomeElevatorGuy use the search function on the dev forums then. I know it’s been talked about before.


Edit, apologies, the place to look is the Dev Hub, and the tool is called Show Decomposition Geometry. You can also search this term on the dev forums.

4 Likes

So I ended up Installing a Plugin called “Mesh Optimization Tools” Now it shows this:

2 Likes

Go in properties, make sure massless is unticked as well as CanTouch, should work after. Not sure if you need to turn off CanTouch as well or just Massless but go ahead and test it out.

Not working, but Thanks!
I made a Video about it.
robloxapp-20210502-0956503.wmv (1,9 MB)

@Toxstxr massless and CanTouched wouldn’t be the issue either. CanCollide is off, that’s enough to turn off Player collisions. CanTouched works differently, but if CanCollide doesn’t work, CanTouched won’t either.

@SomeElevatorGuy I can see the Decomposition Geometry of the adjacent walls cutting into your doorframe. It has nothing to do with the doors. You can test this by removing the doors completely and trying to walk through. Fix your wall collisions.

3 Likes

Yeah, I thought it would work because I had the same issue yesterday but for me, I had a big sword clipping through the ground so I had to turn off massless.

1 Like

As far as I’m aware, Massless affects physics calculations. Like a player swinging a large tool, massless will stop any unintended center of gravity changes. It has little to do with actual collisions as far as I know.

Let’s not get off topic any further.

1 Like

Thank You! That was the problem!

1 Like

Sigh* okay sorry about that, I don’t think I had seen the collisions are off, sorry!

Thank you. I had the exact problem of a sword hitting the ground, and turning off massless fixed it.