Cannot export model as obj

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

I cannot export a single model as an obj.

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.


  1. Load up a model in studio. This is the model I used.

PlaneMesh.rbxm (9.2 KB)

  1. Right click it in explorer and save it as OBJ.

  2. It will not create an obj file, or a file at all.

  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue.


  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke.

Only noticed this now.

This bug is extremely annoying as we rely on obj’s for skins and rendering. I hope this bug is fixed as soon as possible.

1 Like

This has happened to be multiple times on and off, but it seems to work most of the time. It’s usually a random once off for me.

When I insert your Mesh this happens:

The mesh you were importing was transparent, it was likely exporting properly but you just couldn’t see it.

I set the transparency of this model to 0 before I exported it as an OBJ and I seem to be getting intended results:

I made it non transparent, and it didn’t work for me.

EDIT: I resaved the model, and tried again, and it worked.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.