Cannot join games without being connected to VPN

Greetings, ever since I had my internet company changed, I have noticed I cannot join games without using a VPN. I’m currently using fiber optic internet. I can visit almost any other website without using a VPN, play steam games, and go to sites such as Amazon. I’m able to access the Roblox website, but when I click play my screen freezes and Roblox doesn’t load. When this first began happening it would talk about an HTTP error: "Can’t join place [place id] HTTP 400 (HTTP/1.1 400 Bad Request) (Unknown error.). There’s a few other messages that used to pop up in the screenshots tab. Currently, Roblox just freezes itself and doesn’t load whatsoever.

  • This bug happens right as you join a game on the loading screen
  • As said earlier, this bug began happening right as I got fiber optic internet back in September of 2019.
Screenshots



image

I honestly don’t know if it’s something on my end or a Roblox issue. I’ve been using Proton VPN since around September of 2019 but recently due to Covid-19 it has just become insanely laggy since I’m using their free servers. It’s practically impossible to play games as well. I’ve changed my DNS, restarted my PC, reset my PC, uninstalled Roblox, and basically anything else you could think of. I’ve also gone on a macbook to test this as well, still having the same issue. On the other hand, my iphone xs does not have this issue.

In all honesty, I don’t see how you can reproduce this bug unless you actually have it in the first place, I’ve done my best to give out as much information as possible.

Specs:

AMD Ryzen 5 2600 Six-Cor Processor
8.0 GB
Radeon RX 580 Series

4 Likes

Somehow I’m not alone in this, but for me, VPN doesn’t work, which sucks. Someone made a topic about this and I posted my reply.

But after around 19 days, this is not yet fixed by the Roblox Staff. This is kinda’ annoying me honestly on how this problem is not yet fixed and I have to email the Support team just to get this over with.

This message error doesn’t appear on my screen. I believe this is an issue on Roblox’s end, and only happens to certain people. I got about a few of my friends having this issue.

2 Likes

Same here. I can’t seem to connect to Roblox games on my phone or Chromebook with 1.1.1.1 turned on anymore. Have to turn it off in order to join a game, or I’m stuck on the loading screen with the game icon and “Joining server…” beneath it.

2 Likes

Many Roblox fans around the world face restrictions when they try to access the gaming platform. Roblox has been blocked in China and Ukraine in the past and it is blocked in the UAE and Jordan. Even if Roblox is available in your country, it might be blocked at schools or work.

Organizations and institutions take it upon themselves to block access to these games because they are regarded as a distraction and consume a lot of bandwidth. The good news is you can overcome these geo-restrictions by using a VPN. change your VPN to an allowed country.

EDIT: therefor I recommend you to change your VPN, ExpressVPN doesnt block roblox.

From ExpressVPN : ExpressVPN is a very popular provider in the VPN industry thanks to its fantastic speeds and excellent services. It grants you access to servers in over 90 countries so that you will be able to bypass restrictions and enjoy access to Roblox and other popular platforms no matter where you are. For more information on other top recommended VPNs for Roblox, check out the table below.

1 Like

If you have windows 10 installed, are you able to join games by launching roblox from the windows app store?

2 Likes

This problem has happened to me before. I posted a thread about it way back in April 2020. The problem seems to line up with the starting/ending of online school in South Korea, but it could be different for you guys.

I have similar issues. Ever since I moved into a new house my internet seems to freeze a few minutes in a game. Insanely annoying, does not happen to my phone or when I use mobile data. Could be different.

1 Like

This issue needs to be addressed sooner or later, most of my activity on ROBLOX is on VIP servers, and I can’t really do much there without having to turn on the VPN, which slows down my internet down to a crawl and makes ROBLOX quite a bit laggier (connectivity-wise)

1 Like

To add on, this is ONLY my ip address, I’ve gone to many friends houses with the same PC that has never seemed to work and ironically, at their house, it works.

Yes, but considering many features such as copy and paste don’t exist, it is almost impossible to play as I normally would.

Yes, I read through that and found some solutions, none of them worked sadly. What’s weird is that Roblox isn’t even restricted in the US so I don’t see the issue of why this would even happen.

Sorry I didn’t mean to say that you need to use Windows 10 App, I have a hunch for what is causing your issue, and the ability to run from the Win10 App but not from the browser aligns with my hunch. I’m going to confirm with another team and I will try to get back to you later today.

3 Likes

If you are on windows 10, have you tried Roblox from Microsoft Store

Please retrieve client logs, they may have additional information to help the diagnosis (start at step 6):

(also send them to me as a DM, rather than as an email to info@roblox.com)

Would you like me to try and play without the VPN or with it? I don’t think I can play without the VPN but it might help find what’s causing this.

Please try without it (the failure cause), the client logs will hopefully have more information about which specific piece is failing.

1 Like

It says something is wrong with the authorization process. (I am experiencing the same problem as OP!)

I will post a snippet of it here.
“1590758885.55876,6ca0,6 Error: in handleGameStartFailure, msg is GameStartUnauthorized”

If you need the full log file, tell me

I don’t know what is unauthorized, nobody else is logged into my account.
I’ve heard that leaving an old Group Chat can help, but I’ve tried that and it does not work.

Your error is slightly different from 945ft, the OP’s error will cause them to be unable to join any game, your error message normally relates to not being authorized to joining a specific game instance.

Again, I don’t understand what was unauthorized. I am paying for the VIP server, so I should be able to use it normally. It also does not work for other VIP servers I have access to (via Link or the join button)

It really only happens when there are people in the VIP server. If it doesn’t have anyone in it, then I can join normally.

Has there been any update on a fix for this? It’s still happening 10 days after the last post (and nearly 2 months from my post about the problem)

I’m not very sure about OP, but since we have similar issues (having to turn on vpn to join vip servers) that’s why I’m asking here instead of making a separate post.