Cannot load module

I am trying to load an run a module but it keeps giving me the error:

Downloading asset failed for asset id 7179128223.  Is the asset id correct and is the asset type "Model"?



Any ideas why this wont work?

1 Like

When you uploaded the Module, was the Module script named “MainModule”?


not the model but the script yes.

Model??? Have you put the module script inside model before you upload it?
if you want to load model use InsertService require() is to call the modules scripts only
and when you upload it you should not put the script inside a model upload only the script without parent

  1. Make sure the module is named “MainModule” or you can’t require it by rbxassetid.
  2. Make sure .run() is a valid method.
1 Like

no it is not in a model. i mean like when i upload it the name is not ModuleScript but when inserted the script name is ModuleScript

1 Like

It was all working really fine when i got it out of the toolbox but i changed the module id bc i edited the module to remove the gui but then it stopped loading the module

1 Like

Nvm. I just fixed it by running it through a script that had the modulescript as a child then ran the .run function. works now.

1 Like