Cannot load the AnimationClipProvider Service

I’m just trying to play an animation but i can’t cause of “Cannot load the AnimationClipProvider Service.” error.I searched that error on the net but i can’t take a good result how can i fix it?

Heres the code sample.


I’ve had this same issue, It might be because the animation hasn’t loaded (Instance).

Its a bug that has been a problem for a while.

It happens because

  • The player character/humanoid hasn’t been paranted to the workspace…
  • The script runs before the service that controls animation (AnimationClipProvider) loads.

Add task.wait(1.5) to prevent this from happening

P.S this usually occurs after character respawns

1 Like

Not worked is there another way to fix the problem?

You have to add it at the beginning of the script

1 Like

It doesn’t worked


Are you fixed the AnimationClipProvider Service bug?

Had this happen earlier to me, pretty simple fix. I believe it happens when you try to load an animation and the character isn’t parented to workspace yet. So, before cloning your viewmodel do this:

until character:IsDescendantOf(workspace)

All this does is yield the script until the character has been parented to workspace. It’s a pretty hacky solution but seems to be the best and simplest solution I could find.