Cannot open roblox studio

@Infinite_Visions (and @indieuns) I think I had the same issue as y’all.

Support suggested I make a new Windows account. I followed the instructions here and that seems to be the best solution I’ve had so far. It’s worked stably for three or four hours and a few times leaving my computer. Previously everything else I changed failed before that.

Worth a shot if you haven’t done that yet.

Here’s something else worth trying:

Go to regedit and go to the path Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\. Delete the RobloxStudio keys. Your problem might just be fixed.

If that doesn’t work, navigate to %temp% and delete everything you can in the directory. Then, delete everything from the Roblox directory in %localappdata%. Reinstall Roblox, and your problem might be solved.

This worked for me for a previous UI issue I had. It’s worth a try here as well.

2 Likes

Appreciate the tips!

Tried deleting those, and the issue was still not resolved. Unfortunately, my studio just bricked itself on the new account as well. Any clarity or ability to fix this, so I don’t have to add/delete users from the PC/Windows Account level would be great.

It seems to happen if I walk away from Studio for (some) amount of time, and it loses connection to (something) and then can’t recover.

I’d make a new post, but I still don’t have access to this forum, sorry about the bump.

What exactly is the error message, if applicable? If there isn’t an error message, it is most likely the white screen of death issue.

There was another topic about this recently in #help-and-feedback:platform-usage-support and it has not been solved yet, so I’m currently wondering how to fix the issue myself and I can’t reproduce it either.

Try launching studio by running RobloxStudioBeta.exe instead of RobloxStudioLauncherBeta.exe.

1 Like

Hey @SubtotalAnt8185 , it is in fact that “White Screen of Death” issue, and what’s documented in the other thread. Last time this happened, it was resolved when I made a new account, but I’ve gone through torching everything and restarting twice now, and it’s not working this time.

I’ll see if deleting absolutely everything, the other user account, and running it from that launcher the first time fixes it for me.

1 Like

@SubtotalAnt8185 Alright, so, it’s working again temporarily at least, and what I did was:

  1. Totally uninstall every file, temp file, delete every registry key in SOFTWARE for Roblox/Roblox Corporation. (Uninstall via Windows add/remove applications > delete contents of AppData\Local\Roblox > delete registry values.
  2. Delete the Windows account where Roblox failed.
  3. Restart the computer.
  4. Create a new Windows Account.
  5. Install Roblox Studio on a brand new Windows account (it automatically launches)
  6. Exit before logging in.
  7. Go to the temp/local folder, and run the RobloxStudioBeta.exe from there
  8. Open a game place.
  9. Then I just ran around a world a bit, clicked “play here”, played, saved, and exited.
  10. Closed Studio and reopened, and it did not give me the white screen of death.

Temporary disclaimer: last time I was dealing with this issue it could resolve for a single session, but when I returned to my computer “later” it would have ceased to work. I’ll follow-up again if it’s still working later tonight/tomorrow.

1 Like

Hi all, typically these errors indicate a service outage or some other type of site event. We’ve upgraded some of that messaging in the past few months, but its still possible in some cases to see something like this. Generally resetting accounts or clearing registries should not be necessary, but if you are ending up in something like this, please respond back here. Thanks!