Cannot overwrite File > Publish to Roblox As

Reproduction Steps

  1. Open a Roblox game in Roblox Studio
  2. Make a change to the game in Roblox Studio
  3. Select File > Publish to Roblox As
  4. Select a game
  5. Select a place
  6. Press “Overwrite” (Become stuck and does nothing)

See video of steps here: https://twitter.com/BeastyBlake101/status/1558918213450076162?cxt=HHwWhMCgqeH2saIrAAAA

System Information
Microsoft Surface Laptop Studio
Windows 11
11th Gen Intel Core i7-11370H 3.30GHz
16 GB RAM
NVIDIA GeForce RTX 3050 Ti Laptop GPU
Intel Iris Xe Graphics

Beta Features
Enrolled in Beta Channel (Accessory Fitting Tool, Canvas Group, CSG Version 3, Face Recorder, Intuitive Debugger, Live Animation Creator, New Mesh Importer, New Text Chat Service, One-click Collaborate Button, Particle Flipbooks, Save rig with Animation, Script Editor API, Scripts are Non-Strict by Default, Start Page List Display)

Expected Behavior

The place should be published and overwritten. Alternatively, an error message should appear in output explaining why the publish failed.

Actual Behavior

Pressing “Overwrite” freezes the pop-up in an idle state until cancel is pressed. No error messages in the output appear.

Workaround

Copy all of the items from the Workspace, ReplicatedStorage, ServerStorage, ServerScriptService, StarterPlayer, and so on… over manually.

Issue Area: Studio
Issue Type: Other
Impact: Moderate High
Frequency: Constantly
Date First Experienced: 2022-08-14 15:00:00 (-05:00)
Date Last Experienced: 2022-08-17 00:00:00 (-05:00)

5 Likes

Hi there, we are investigating this issue further.

Are you able to share the size of the RBXL file?

6 Likes

Hi, the RBLX file size is 1.89MB.

Are you able to provide any of the following for us to repro the bug:

  • studio log for the session when it hangs
  • the place file itself
  • if you keep waiting, what happens to the hang? Will the output window ultimately print an error?
  • placeId of the source place (arcade island x dev build)
    Thanks!

Unfortunately, I am having the same problem… Whenever I publish my game, it fails to do so. Also, I can’t overwrite it either

Can you share the info requested above to help us investigate? Thanks!

0.540.0.5400503_20220824T022735Z_Studio_FB1D0_last.log (44.5 KB)

I think this is the studio log, not too sure. I am unable to provide the place file, however this is a link to the source place: PR Map_Main Branch - Roblox (placeId:6987628947), and I am attempting to publish to our test server: PR_Beta_TestServer - Roblox (placeId:9157190573).

I’m basically just staring at this whenever I attempt to overwrite (does not hang):

The first time I tried, I waited for around 5 minutes and nothing happened (no errors either) so I tried restarting my PC and attempted again but it was the same result after 10+ minutes. Additionally, studio does not hang at all, I’m able to press the “Cancel” button and everything returns to its normal functionality. My PC basically has the best components money can buy at the moment and it’s never had this issue in the past. My network is also running as expected currently. I’m on Windows 11 if that matters. The file size of the source place is 20.061MB and the place I’m attempting to overwrite is around the same.

I tried overwriting a fresh place to another unused place and it worked, for some reason this issue seems to be tied to one of the two places I linked above.

Edit: Tried publishing from a local copy of the place and did not work. “Save to Roblox As” did not work. Reinstalling Studio also did not help.

Edit: One of our developers tried it for the place but it didn’t work for them either, it seems like its an issue regarding the place itself and unrelated to my account.

Hi,

studio log for the session when it hangs

Studio Log (319.1 KB)

the place file itself

Unfortunately, I cannot share this.

  • if you keep waiting, what happens to the hang? Will the output window ultimately print an error?

Nothing, even after several minutes. No output errors.

placeId of the source place (arcade island x dev build)

Arcade Island X Dev Build: 8688293519
Arcade Island X Release Build: 2185497593

Something else that I’ve noticed is that this issue is only occurring between different universes/experiences. File > Publish to Roblox As under the same universe but a different place still works.

Apologies for the delayed reply - I just started at university. Please let me know if I can provide any more info. Thanks for the help.

1 Like

Hi. Thanks for the reply! I just read the log you provided. Not sure if you can help me understand this. In the log, I see studio getting launched with placeId = 2185497593, which corresponds to Arcade Island: Working Arcade (release build), see this line

C:\Users\beast\AppData\Local\Roblox\Versions\version-545162fae686423a\RobloxStudioBeta.exe -startEvent www.roblox.com/robloxQTStudioStartedEvent -ticket w19A1FM77_Wwz1V6d4-GnoPAnOzC_UoLyh90QOTHf_o7EUd9fHOAjoxuVpmu_YJ-sqcc7AGFWvnl8JOZvx0X9458krLLCxxjnHImlvAFr3EU3poaEhiE47feypjoQX8ZleidZakVxwlike8_UdaYthnv1u2Sx5dAQDPXrj9FvlAIEpufEPk6m985uP_C-B-sL2lIQBqxcZ3nygoFA6bv4xS-nw5S2HBY3dbGUgEfaTA -task EditPlace -universeId 762495947 -placeId 2185497593 -readyEvent RBX-293026359-10520-16862-1881192112321212614772 -browserTrackerId 142779990688 -channel zqtitanstudiorelease -protocolString roblox-studio:1+launchmode:edit+gameinfo:w19A1FM77_Wwz1V6d4-GnoPAnOzC_UoLyh90QOTHf_o7EUd9fHOAjoxuVpmu_YJ-sqcc7AGFWvnl8JOZvx0X9458krLLCxxjnHImlvAFr3EU3poaEhiE47feypjoQX8ZleidZakVxwlike8_UdaYthnv1u2Sx5dAQDPXrj9FvlAIEpufEPk6m985uP_C-B-sL2lIQBqxcZ3nygoFA6bv4xS-nw5S2HBY3dbGUgEfaTA+launchtime:1661998897209+distributorType:Global+userId:28886345+task:EditPlace+placeId:2

but in the video, I see studio has Arcade Island: Dev Build open, from which you did “publish to roblox as”. Should we expect studio to launch with placeId=8688293519 instead?

Hi, I believe I may have made a mistake reproducing the error by having multiple Studio instances open.

Here is an updated studio log. This uses the Arcade Island X Dev Build and attempts to publish to Arcade Island X (Release Build). This should hopefully make more sense.
Studio Log (55.3 KB)

Please let me know if this is what you are looking for, and if I can clear up anything else! :slight_smile:

Hi,

I figured out the solution for this studio bug after making a copy of my place where the issue arises and isolating all the potential causes. I had narrowed it down to a specific restaurant model until I came to the realization that I was receiving the “Grant All Permissions” prompt when attempting to overwrite during successful attempts, but not during unsuccessful attempts. From this realization I deduced that the issue must be somehow involved with sound asset permissions since it was preventing this prompt, so I isolated all sound objects from the problematic model into an empty baseplate and surely enough, the new place was no longer able to overwrite. On closer inspection, there was a typo in the SoundID property "http://www.roblox.com/asset/?id=http://www.roblox.com/asset/?id=12517136" (should be "http://www.roblox.com/asset/?id=12517136", also I know the format is outdated, its from a very long time ago). After correcting this typo, everything began functioning as intended.

I then decided to analyze @BeastyBlake101’s studio log and noticed he also had a SoundID typo "rbxassetid://rbxassetid://9809973085", so I tried pasting that into my sound object and it resulted in the same issue. Correcting the SoundID to "rbxassetid://9809973085" seemed to resolve the issue but I can’t tell if this is the sole issue associated with his place until he replies.

Just wanted Roblox engineers to be informed because I noticed there are quite a few cases of this issue remaining unresolved due to a minor edge case, and obviously most people are not willing to share their place file (which was required for me to troubleshoot this). Perhaps some sanity checks should be implemented to catch the issue and prompt developers to correct their SoundID formatting (or just bypass it entirely because something as minor as this should not be preventing developers from publishing). I’m assuming this has something to do with the new audio asset privacy update due to the fact that the problematic sound object was forgotten in ServerStorage for over a year now and only became an issue recently (not able to provide an exact date as I had not attempted to publish any updates for a few weeks prior to my report on August 23rd, 2022).

Here is a file where the issue can be reproduced:

SoundObject.rbxl (34.7 KB)

You will notice it’s able to be published normally, and the issue arises when you do “Publish to Roblox As…” or “Save to Roblox As…”. Upon correcting the SoundID property of the Sound object located in Workspace, the issue is resolved.

1 Like