Cannot publish place using publish to

We’re trying to push an update to our game (Vehicle Simulator), yet it fails to publish for some reason. It shows the version as having been updated, but it doesn’t say “Published” next to it. We’ve tried downloading the place and publishing, yet it fails to publish at all. It claims that the place is updated, yet when we check studio, none of our changes are there. I’ve also tried reverting to the version that was recently published, and it didn’t work.

Started happening a few days ago, as seen here.

Repo steps:
Option 1: Try publishing from place A to place B (Using the publish to option).
Option 2:
Try publishing from (VS: Testing Grounds - Roblox) to ([🏁 RDC22 🏁] Vehicle Simulator - Roblox), and it fails to push the changes (Silently fails).


Can you please carefully follow the instructions here to get and privately send a log file from a Studio session where it silently failed to publish? Please also record the date and time (including timezone) when you attempted this and include this information in your topic.


I’ll have my boss reply ASAP with the log files.

Hi Belzebass. Have you been able to successfully publish places since seeing this issue, or is the problem ongoing?

An Issue similar to this happened to be in the past, turning on Team Create and publishing solved the issue.


log_02C4F_1.txt (8.8 KB)
log_2AD05_1.txt (8.5 KB)
log_2FFBC_1.txt (21.4 KB)

1 Like

We have not been able to use the publish to feature from one place to another since this issue cropped up a few days ago. Not sure if it works now (Will check ASAP again), but my boss (Simbuilder) uploaded the log files from his PC.

I know the solution to this, probably you left your computer on for a long time. If it happened in a different way, I don’t know it, but the solution is simple. First turn off your internet, it will kick you out of the studio when your internet turns off. Then open your internet and enter Studio, when you open studio, it will write something like Auto Save File Detected on the screen. When you press Open, the files will come, when you click the last file, your game will open and when you press the Publish button, you can extract the new version of your game. I hope it helped :slight_smile:

Thanks! The first two logs seem to be from the main game (171391948). The third log is from the testing grounds (3656676387) but seems to be fairly old. Can you create a new log by:

  • Opening Testing Grounds
  • Publishing To the main place
  • Closing Studio completely

and send that to me?

1 Like

Scratch that. We are able to reproduce it with a minimal setup internally. This will happen any time you try to publish over a Team Create game. In the meantime, you can disable Team Create on your main place in order to publish the testing grounds over it.


Thank you so much for being able to repo/instructions on how to fix!

As an addendum, you will also need to manually open the place after “publishing” to it and File>Publish To Roblox, as “Publish To Roblox As” seems to be behaving as “Save To Roblox As” (which we are also investigating)


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.