Cannot turn intellisense/autocomplete off

Intellisense/autocomplete appears to be forced on. The checkbox is unchecked yet it’s still there. I’ve never had autocomplete turned on before.

unchecked checkbox

Not sure when this started happening, it’s been a while since I’ve last used Studio.


(The expected and prior behaviour is the autocorrect popup not appearing at all.)


When initially reading I thought it might have been an issue with not restarting studio. I unchecked the “Enable Autocomplete” property and restarted studio, and discovered that although it gives you the little tab under the piece of text. When you press enter it does not complete the text.

Ex: When typing ‘function’ into the editor it gives you the little tab, with the option enabled, I discovered when you press enter it completes it for you. But with the option off pressing enter just puts you on a new line

Also photos:
This is what happened with the autofilled disabled after pressing enter.

However with the option enabled, it does it as normal.

As such I do not believe this is a bug. I think the little tab that appears is always supposed to be there and the auto-fill property only affects the editor when you press enter when an auto-fill is selected in the tab.

If I’ve had autocomplete disabled since forever, but then recently the autocomplete ui starts appearing, but it does nothing, that’s a bug.

I really do expect “do nothing autocomplete related” to be the intended behaviour of turning autocomplete off, not “show the autocomplete pop-up but it does nothing.”
Especially given the fact it’s done the former for years. This new broken behaviour is clearly a bug, I can’t believe you’re actually disputing this as someone who has presumably always had autocomplete turned on, and may not be familiar with how the setting used to (and should) behave.

1 Like

I’m not too good at programming yet and so i rely on autofunction filling when i forget the functions full name, but this would be a hassle if i were to known exactly what i wanted to code and had a high wpm count. This should be fixed