Cannot type { .. replaced with (

I cannot type { in the Script Editor. Every time I do that, it’s replaced with (.

I have a MacBook Pro with a Swedish keyboard. Left bracket is typed with shift + alt + 8 while the left parenthesis is shift + 8. This bug only happens when I code and has only been happening this past month or so. Everywhere else I can type { fine, including the “Find” menu in the script editor.


We are looking into this. Tragically, we are all on US Keyboards and this doesn’t seem to repro for us. We will keep investigating.


This happens to me too, using a Norwegian keyboard (similar to Swedish keyboard like OP).
This means the issue could be with nordic layout keyboards. The key works normally in every application except Roblox Studio, and not being able to type { is extremely annoying when scripting as you can’t create tables. My current workaround is rerouting a different key to {.

(This is only the { key; it does not happen with the } key)

1 Like

I have a swedish layout and I’ve never had this problem.

Are you using MacOS? I’ve never had this problem on Windows, only when connecting a keyboard to a Mac.

I’m on windows. I’ve never tried in a mac.

1 Like

This happens to me too. I use a Norwegian keyboard, Windows 10 Home Edition. This only happens with the } key, not the {.

1 Like

You can find steps to reproduce on a US keyboard in my report here:

Edit: I copy paste it here since it does not go through approval due to being a duplicate post

In the Roblox Studio script editor it is not possible to write left curly brackets when you are using a Swedish keyboard layout on macOS.

It is limited to the script editor, so it is possible to write curly brackets in other input fields in the editor.

Steps to reproduce:

  1. Go to System Preferences -> Keyboard -> Input Sources in macOS
  2. Add keyboard layout “Swedish - Pro” and set it as active keyboard layout
  3. Open up a script in Roblox Studio and place the caret in the script editor
  4. Press the Option+Shift+8 combo to write a left curly bracket {

Expected results: A left curly bracket character should be inserted into the script

Actual results: Left and right parenthesis characters are inserted instead ()

Current workaround: Focus another input field in Roblox Studio, write a left curly bracket character, cut and paste it into the script editor.

macOS version: 10.15.3 Catalina

I also experience this bug; I can not type curly braces inside the script editor, as before mentioned, it is possible to type these braces anywhere else but the script editor.

Since I also use a Swedish keyboard, I press shift + alt + 8/9 for { and } respectively. My keyboard does not have dedicated keys for these characters, so I have to use these key combinations to type them. (By default it was manufactured that way). Also, it is worth mentioning that I am not using anything special to access these keybinds. I should emphasise that I can type “}” but just NOT “{”

In the beginning, I did suspect it was a Roblox shortcut that interfered with this bind, but I concluded that this was not the case since, I could use it outside the script editor like in text-GUIs, and I could type the braces in built-in Studio search bars like the one in the toolbox or the explorer.

I have tried resetting settings, re-installing studio and reassigning keys. Changing language layout to British English allowed me to type the braces , I have yet to try other languages. Though I have to press “shift + Å” which is awkward.

A bit about my macbook:
OS: macOS Catalina Version 10.15.2
Model: MacBook Pro (Retina, 15-inch, Mid 2015)
Processor: 2,2 GHz Quad-Core Intel Core i7
Memory: 16 GB 1600 MHz DDR3
Startup Disk: Macintosh HD
Graphics: Intel Iris Pro 1536 MB

For now, I am using visual studio to bypass this; sorry for reiterating what the others have already said but I do think this issue should be addressed and be given more time and effort in researching the underlying issue.


This is still happening 2 years later and makes it tedious to work on code in Roblox Studio for me.

I’m using a Finnish keyboard layout on macOS, and use Shift + Option + 8 to make a left curly bracket, but in the script editor, it results in parentheses, instead of the expected result of putting curly brackets.

This makes it fairly tedious to work with tables at all and results in me having to copy-paste curly brackets into the script editor, and if I copy any code or anything else, once I have to make a table again I will need to copy the curly brackets again.

Please fix :pleading_face:

I’ve found a solution to this problem by going to Studio Settings > Script Editor and disabling the setting called “Auto Closing Brackets” (There’s a small downside: it won’t auto close brackets)

1 Like

Just ran into this bug and disabling that setting solved it for me for now. Thank you!

On another note, this seems like a pretty severe issue, not being able to type curly brackets is almost the same thing as not being able to code at all. Has anyone at Roblox managed to find a repro / looked more into this issue?

Can repro internally. Looking into it…


A fix is released. Anyone who worked around the bug by turning off “Auto Closing Brackets” can now try to turn the setting back on to save a few key strokes. Let us know if you still see a problem!


This topic was automatically closed after 16 hours. New replies are no longer allowed.