Cannot Use Move Tool In Play Mode

I cannot use the move tool in the toolbar when I hit run.

Expected behavior

I expect to be able to move it.


I’m also experiencing this, it also applies to the scale and rotate tools and I also cannot open the toolbox or terrain editor while the game is in play mode. Not using the movers beta.


Thank you for the bug report. This is intentional (if experimental) behavior for the new “Faster Play Solo” beta feature. This beta is intended to speed up time to launch play solo in Studio, and one of the optimizations we made was skipping loading certain editting features which are less commonly used in the test modes.

As a temporary workaround, the beta can be disabled through the beta features dialog. As a more permanent solution, we intend to release a setting to force-enable these features before we finish the beta. We also welcome feedback on what editing features you use during test modes that you would want in test modes.


Moving, scaling and rotating (simple) assets are very useful features when playtesting. Selecting and dragging still works, but moving, scaling and rotating doesn’t.

Please consider optimizing the draggers rather than disabling them.

I find myself using them when I’m working on new systems in separate testing places. Also very useful to play with physics. Recently used it for testing IK constraints on a dummy, etc.

I definitely don’t use it every playtest, but I use it often enough for it to be noticeable.


The “faster play solo” beta saves me, on average, about two seconds when starting play solo. And for those two seconds, studio functionality is being neutered for the entire play session. That’s a pretty steep price to pay for not much gain. The very reason I’m testing in studio rather than on the game client is specifically to have access to the very tools that this beta strips away.

I honestly find it incredibly disrespectful that whoever worked on this beta feature made the executive decision that developers simply didn’t need access to the toolbox, asset manager, or studio draggers at runtime, all without ever polling or consulting the developer community to gauge their use. I don’t know if you worked on this beta, but it’d be hard to believe that whoever did ever actually uses studio, because if they did they’d know that moving things around and resizing them at runtime is basic functionality that should never be limited and is something most developers do almost every play session.

On top of that there was no announcement of this beta feature, it was just turned on one day. Anyone who, like me, has beta features set to automatically enable themselves, were left completely in the dark as to why all of a sudden the draggers were bricked at runtime. No announcement with a “hey, if you’re noticing that the draggers are bricked, this might be why!”

Please, for the love of god, be more transparent with the developer community when making changes that have the potential to completely tank workflow productivity, especially when the “gain” is as negligible as it is here.


I experienced the same issue. It was an automatic change for me since I have beta features turned on. The solution is to turn off the beta feature called “Faster Play Solo”. For a permanent solution, as mentioned by others in this thread, there will be a button to turn this off. The purpose of this feature is self-defeating, since when I go to playtest something I typically intend to use it as a live editor. Not being able to use scale, rotate, move, and even transform tools in this mode negates a large portion of why it even exists.

TLDR; to solve this issue turn off the beta feature called “Faster Play Solo”

1 Like

same thing. i hate this update/bug.

1 Like

Does this also explain why the toolbox disappears whenever I play test? It’s very jarring for UI development and play testing as my viewport is no longer centered and is now stretched horizontally.


The toolbox is intended to remain where it is while in play mode, just blanked. That looks more like a potential bug with the docking system to me - I will forward it to the appropriate team.


Hello! Much like some replies above, I use the 4 standard selection tools (Select, Move, Scale, & Rotate) in play test sessions quite often. Especially when working on things that update in real-time, such as object positions based on updates to other objects. There are a plethora of use-cases that rely on all four main selection tools being used outside edit mode.

I’d also be interested to know a complete list of tools that get disabled during play test sessions. This helps us find workarounds (such as F3X) faster and not have to find out in-the-moment of testing. :smile:
(Was this mentioned somewhere that I may have overlooked?)



I think this affects the default Roblox Animator as well. When I want to switch to “Move” or “Rotate”, the animation editor goes out of focus. Strangely this still happens after I have Fast Play Solo Beta feature disabled.


I’ve had to deal with this for the last couple of days. Please fix this!


I would prefer to have the ability to choose what plugins run during my play session, instead of going with all in or nothing approach. Additionally, it would be great for UX to mark those buttons as disabled when the feature is enabled, along with a tooltip message that explains why it is disabled. I have filed a bug report, because I thought that this was a bug due to the lack of communication from the UI.


Please fix/do not make this a feature I frequently use move and resize tools to test while playing.


I think this been a thing, you just press R to switch between move and rotate or vice versa.

1 Like

I might as well comment here because this should have never happened in the first place tbh

Disabling features that are used less is fine but I can promise you that the move tool is used a lot more than you think. Also would it be possible for you to provide how y’all know what tool is used less?

This isn’t really a good workaround, why do we have to choose between faster load time and being able to use a tool?

I’m a little confused with this, are you saying that there will be a setting to choose what gets disabled? Or are you talking about forcing the tools disabled before the beta is finished?

Omg someone posted a bug report about it, thanks for that because I ran into this as well.

The only thing that seems to work in fast play-solo seems to be dragging but all other mover tools are broken and it’s a bit frustrating to say the least.

Couldn’t properly test my ragdolls.

After further consideration and testing we’ve decided to re-enable the Move, Scale and Rotate tools in play modes. Other plugins like Toolbox, Asset Manager will remain disabled by default, but with the setting to reenable everything. Thanks all for the feedback.