Can't add local plugin

Does this question belong in Scripting Support?

I want to write a plugin, but having trouble starting out because:

Trying to add a Local plugin following Intro to Plugins instructions at:

EmptyScriptAdder.lua is in my Plugins folder. Clicking the Plugins Folder icon confirms this.

Toolbar button shows up greyed out, but never becomes clickable and Manage Plugins remains always empty. The new local plugin never shows up in Manage Plugins.

I’ve copied and pasted the code from Step 4 of “Adding a Toolbar Button” and also tried copy/paste the code from “Supporting Undo/Redo” section. I right click the Script and select “Save as Local Plugin…” each time, still no success.


Um … still don’t understand what’s going on or why … but after fiddling for a long time:

  1. I added a different plugin CSG Curve Cutter by Mr_VrHeadSet using Find Plugins button
  2. then closed the Manage Plugins editor tab
  3. then clicked the Home tab in the Studio ribbon bar
  4. then clicked back to Plugins tab in the ribbon
  5. and suddenly BOTH icons for my Local plugin and the third party plugin were active and available for use.


Why did this work and why did I have to do these steps that are not mentioned as a requirement in the Intro to Plugins instructions?

When you use “Save as Local Plugin…” or install a new plugin, Roblox automatically refreshes all plugins. If plugins aren’t refreshed, you have to manually restart studio to make Roblox Studio reload plugins in the Plugins Folder. I’m guessing you edited the .lua file manually to copy paste the code, so it didn’t update properly in studio.

Thanks for responding.

I did try re-starting Studio. I did not manually edit the .lua file.

Now, after still spending more time fiddling around, I’m thinking that the UNDOCUMENTED REQUIRED step is:

  • Close the Script editor tab for the Plugin Script that you just did a Save as Local Plugin for

As far as I can tell, the Intro to Plugins instructions does not describe this step anywhere.

1 Like

Are you using team create by any chance? I’m not sure if this happens always in studio, but I know as a fact that scripts don’t save until you close the script editor in team create.

Nah, maverick / lone wolf for the time being. Haven’t looked into Team Create yet.

Oh, I think I know what your issue is. You can’t use buttons in the plugin toolbar unless you’re currently looking at the viewport. You don’t have to close the script editor, you just have to click out of it to view the main viewport.

Edit: Looks like that’s the issue.

1 Like

Local plugins don’t appear in Manage Plugins because that panel is specifically only for installed plugins. You have to manage local plugins through your own file system or through the plugin itself (not creating any plugin materials if conditions aren’t being met, for example).

1 Like

Yes, that’s it. Thanks for showing.

This could be explicitly stated in the Intro to Plugins instructions, which is supposed to be step-by-step for those who don’t already know.

Could be a feature request for Manage Plugins to “manage all plugins” and instead of

  • “Plugin_Title by [Plugin_Author]”

it could say

  • “Local Plugin found in Plugins Folder”.

I might follow the process for requesting a post in the Feature Request section.

If you’d like to create a Feature Request for this, feel free to do so. Just make sure you follow the requirements of a Feature Request and pass it by post approval.