Can't automatically equip a tool with no handle

  1. What do you want to achieve? I want the tool that is given to the player by the seat to be automatically equipped, and all it’s scripts properly activated.

  2. What is the issue? I am unable to have the tool properly equipped automatically.

  3. What solutions have you tried so far? I tried multiple ways of activating or equipping the tool, none of which have applied the scripts associated with the tool.

The tool does not have a handle, so :EquipTool() will not work.

	local humanoid = player.Character.Humanoid
	local TIE = game.ReplicatedStorage.TIE:Clone()
	TIE.Parent = workspace
	player.Backpack.Plane.Active = true

Have you set the RequireHandle tool property to false?

As I said, it does not possess a handle, therefore the RequireHandle property is appropriately set to false.

I have found that instead of using :EquipTool() you can just set the Parent of the tool to the Player’s character. I apologize for needlessly creating a thread.

1 Like

You can try to move tool to character.
You just said that

Hello! Thank you for your interest, however please do not reply to this thread. I have found a solution myself whilst awaiting help.

I wrote this in moment when you replied.