Can't be accepted into a group

I noticed this happening after changing my username to one with an underscore (El_Capitan). When someone accepts me into a group, it doesn’t actually accept me. The group says that I’m in, but on my side, it shows the page you get when your not in a group.

EDIT: It has put me in now, just a weird caching error maybe.

Here’s a screenshot of what is happening exactly.

Here’s the group

Quick follow-up question: Is this still happening? I ran into this once but it went after a while (by a while I mean a couple of minute). It could be a cache issue – did you try full refreshing the page?

1 Like

Normally it takes some min, before you actually show up.

Yeah it took a few minutes. Just weird that it wasn’t instant, as group joining has never cached.

I had the same issue a few days ago, it took several minutes before it worked again. Refreshing pages also didn’t help.

Yeah - this isn’t new, sometimes it will say you’re in the group but as the rank “Guest” (using :GetRankInGroup() and :GetRoleInGroup() will return 0 and “Guest” respectively too). This fixes itself over time.