Can't change roblox studio's language

I’ve been trying for a long time to get my roblox studio back to english language, sinse this feature exists, and I just cant. Im sick of using studio in BR Portuguese (my systems language) because some translations are wrong and translations for things like material names that are enum items and others that are objects properties are not translated in code, so it just make it harder to use.

When I change the Studio Settings > Studio > Language setting to English or any other language than System’s default, literally nothing happens, even if I restart the studio or even if I reinstall the studio.

A friend of mine said he was also facing this problem and he solved it by formating his windows, but I wont do that.

Recorded a video showing the problem:


Can you provide your logs for both the new and old instance of Studio in this repro, as well as a copy of your GlobalSettings_13.xml from %localappdata%\Roblox from before and after?

1 Like

Just posted it on log-files’t-change-roblox-studio’s-language/1791964

Can you right click GlobalSettings_13.xml (not GlobalBasicSettings_13.xml) > Properties and check if the file is set to Read Only? If it is, disable that and try again.

If not, can you make sure all instances of Studio are closed, delete GlobalSettings_13.xml, reopen Studio, and try changing the setting again?

Read Only property of GlobalSettings_13.xml was already disabled.

I deleted GlobalSettings_13.xml and reopened as you asked, but it is yet with the same issue, the change is having no effect just like before.

I’ve seen that changing the language setting on Studio effectivelly changes this line on GlobalSettings

<string name="DisplayLanguage">en_US</string>

but no matter what that string is, Studio always opens on my system’s language.

Following up on this!

Are you still experiencing this issue, sir?

Hey, for now I already formatated the windows and things went back to normal. Thanks

I’m glad to hear that!

Thanks for the update!

1 Like