Can't create new Collision Group in Collision Groups Editor

Click on Add Group

And then the Add Group button disappears and this error occurs

I tested this without any plugins on a new place file and it still occurred

System Info: Intel Core i9-9900K @ 3.6GHz, 32 GB, NVIDIA GeForce RTX 2080 Ti

Beta Features: Advanced Explorer Filtering, CSG V3, Explorer Services Cleanup, Face Capture, IKControl Joint Constraint Support, Live Animation Creator, Material Generator, Multi-Cursor Script Editing, New Character Controller, New Text Chat Service, New Text Chat Service, Notched Screen Support, Save rig with Animation, Scale factor for Models, Selection Improvements

A private message is associated with this bug report


Good to hear it is not only me who gets this error. My friend also tried to make new collision groups on a brand new place, and we both got the same error as you.


This appears to be caused by an error in the migration of an internal UI component. It’s looking for some theming that applies to the newer version, instead of for the older version.

We are going to work on a fix, and investigate if this same bug happened anywhere else, thanks for the report!

It’ll take a while, as unfortunately due to the nature of this bug, we can’t simply unflip something, and releases can sometimes take a bit. In the meantime, please use this in the command bar:


This may prove useful, for some reason when I tried to add a collision group and failed, Roblox Studio partly didn’t read my mouse inputs anymore. Left mouse click on a part to select it didn’t work. However, if I open a new place, everything works perfectly fine.

System info: 11th Gen Intel(R) Core™ i7-11800H @ 2.30GHz, 16GB RAM, NVIDIA RTX A2000
Mouse: Logitech G402

Is there any method that will allow to create a collision group through the console?

If I remember right:


I’ve updated my post to reflect this, since a fix is going to take longer than we’d like :frowning:


For me, I cannot even get the table to show up for the collision group / edit it from the collision group editor.

If anyone is wondering how to manually set it here is the command to run in the command bar:

1 Like

Good news! We were able to get a fix for this out earlier. It took a few Studio restarts for me, and making sure I closed all Studio windows, but this should now be fixed.


I’m having the same issue, its good that Roblox is getting this stuff fixed but its still frustrating. Not sure why Roblox needs so many UI updates but its defiantly taken a toll on the engine. Hopefully now that were a year in we can see a fix for these issues soon.

Not sure if i should mention it now here but it does not work at all


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.