Can't dock widgets

I can not snap my properties window under explorer.

image

It will let other panes be docked but it forces properties to be stuck on Explorer.

7 Likes

This may or may have happened due this: https://www.robloxdev.com/api-reference/function/Plugin/CreateDockWidgetPluginGui

When I used this for a plugin, it now no longer works for me it will not make a window, and yes I have kept refreshing studio.

3 Likes

It’s still broken, I don’t want to dare try to move any of my widgets like explorer or properties because they do not want to snap back.

1 Like

Can confirm same issue every now and then.

1 Like

With how long it’s been around with no response I feel like it’s being ignored.

2 Likes

I have this issue on Mac

My fix is to put RbxStudio app on full screen and drag/drop correctly

2 Likes

Closing and reopening Roblox Studio seems to fix the issue when it gets stuck in this state. This is definitely still an issue in Roblox Studio on OSX.

1 Like

I may have found the fix, I think you have to close every widget made from a plugin, and then you will be able to dock studio widgets. However, this only fixes the bug half of the time.

5 Likes

I’ve also been experiencing this, but it’s not just certain panels or certain places. If I undock anything then I can never re-dock it no matter where I put it. I’ve tried restarting Studio and it does nothing.

Edit: Also just tried uninstalling both Roblox and Roblox Studio and I’m still having the issue, however I’m not 100% sure I was able to actually reset all of the data, since the widgets that were open previously were still open after reinstalling.

2 Likes

Also, at the same time, plugin widgets from a plugin of mine stopped having sort of window border things around them. I think that’s probably related.

1 Like

had the same issue too
just enable full screen and then dock the widgets

2 Likes

Still happening, Video of unexpected behaviour:

Issue still persistent. Current work around is to go full-screen, close any widgets created by plugins, and double-click the toolbar of the widget.
May have to do with “overlapping” widgets when docked, another issue I’ve had happen on Windows and OSX.

Either this issue is getting ignored and made a low priority, or it’s a regressing bug.