Can't equip outfits that include items you no longer own

When you delete a clothing item or trade away a limited item, outfits you previously saved with said item are normally able to be equipped with the exclusion of the item.
What happens now is, it will only apply the skin colour of the outfit to your current outfit. Without refreshing the page, when you switch back to the recent tab it will say that it has equipped the remaining items from the outfit, but when you refresh, it’s just the stuff from your last outfit.

Normal warning pops up

My body colors change to those of the attempted outfit, and it appears to unequip my current items. (If the items in the attempted outfit were in my recents it would show them as equipped) - This is without refreshing the page.

To my point above, in this example, when trying the same outfit i tried above, it’s showing the top hat as equipped, but none of the clothes I actually am shown to be wearing.

before refresh – (appears to be trying to show that it has equipped the requested outfit) The top hat is on my avatar because in this example I was wearing it before i tried the new outfit. :

after refresh (correctly displaying what is, incorrectly, equipped on my avatar):

Refresh the page and now all my old things are shown as equipped again.

The same will happen with an outfit that contains a clothing item that you deleted from your inventory.

Im using google chrome but i also get this behaviour on Safari.
This doesnt occur on mobile or through the avatar editor service that is used in games such as Catalog Avatar Creator.

Expected behavior

Should be able to fully apply an outfit, just with the exclusion of the item(s) no longer owned.

Page URL:


Thanks for the report! We’ll follow up when we have an update for you.

As more and more UGC items get deleted every week, this bug gets even more annoying…