Can't Import Custom Skinned Rig (Invisible)

Hello, I have created my first ever mesh deformation rig in Blender. However, when I try importing it into Roblox Studio, it appears to be invisible.

Rig in Blender:

When I try importing it into Studio:

What I’ve tried:

  • Importing the rig as only one part as opposed to having other parts parented to it in Blender (doesn’t make a difference)
  • Renaming bones
  • Making my rig bigger/smaller in Blender
  • Inversing normals (the normals are fine since I imported the mesh into Roblox with no issues)

If someone can help me ASAP, that would be amazing! I’m using this for an accelerator game demo, so it’s kind of urgent.

Sometimes ROBLOX studio enjoys to act up, did you try re-opening the project and trying to import the model again?

1 Like

I tried reinstalling Studio, opening different places, etc. It doesn’t work.

Did the studio give anything in output when you have imported the model? Is the armature rig set up correctly?

Quite unsure what specifically could result such a problem as anything I uploaded as an FBX mesh deformation rig was working fine.

Output works fine.

Also, what do you mean by “armature rig set up correctly”? This is my first time doing this sort of thing, so I’m not sure if I have it up right.

I mean, the rig works perfectly fine when I animate it in Blender, etc. What do I need to make sure to do?
how my rig looks
me moving it around

What makes me a little bit confused is this bone:

Back when I started rigging objects in blender I have been following a tutorial ( Simple Rigging In Blender - YouTube ) which provides a detailed explanation on how the armature rig would be set up properly. I am not sure if that’s the cause but it feels like an armature is the reason of the problem.

I added it to make it more comparable to the Roblox rigs I’d make, but I can try removing it and see what happens.

Update: I removed that bone, and it’s still giving the same issue.

This actually happened to me before. I dont remember how i fixed it, i think i just selected the rig and the mesh and then exported as an fbx with “export selection” marked but im not sure.

I can guarantee that I am selecting everything as I tap A before exporting my model as a .fbx.

Currently searching up tutorials that might potentially help you. Try comparing what you’ve been doing so far with them:

What i mean is that there could be something in the blender file thats having issues with exporting. You dont have to select everything. I only export this in my case (with the export selection only box) and it works. Not every single thing inside the rig

This tutorial worked as it seems to bug out when I would add the extra parts (that were parented to the bones of my rig).

However, is there a way to, for example, parent the nose to move along with one bone?

Merging them into one part and making the weight 1.000 doesn’t work.

Seeing that this got marked as a solution, what specifically was wrong?

1 Like

Yeah, simply create a bone which would end at the nose.

1 Like

won’t work for some reason?
note: the nose bone is parented to the head bone

I’m not sure why the eyes and eyebrows work. Do you have any suggestions?

You’ll have to parent the bone properly, I don’t think there’s a way to bypass it. Ears and eyebrows work because you have already inserted a bone that affects them. The point of my statement that you had to extrude a bone straight to the nose without breaking the armature. I’ll try bringing examples of mine, although it’ll be painful to find proper images on mobile.


Not the best example but if you could see the armature on the gif provided, you can separatedly deform parts of the mesh that you’ve added the bone to. Extruding it all the way towards the nose would allow you to deform the nose without bringing much changes to the mesh itself.


Thank you so, so much! This solution works wonders. : D

1 Like

I’m glad that my tutorial could help you a bit even if it is a mess in grammar. English is not my primary language.

1 Like