Can't import to roblox the leaf texture of my tree made in blender


I made a tree in blender and i’m kinda stuck, I can export my model from blender to roblox but i can’t add the leaf texture in roblox… Any idea how I could resolve this (tried to export in fbx and obj alrdy, same results) ?

The model in blender :

The model in Roblox (oof) :

Here is my blender file :

Tree.blend (658.7 KB)

Thx for the help :slight_smile:


Render the trunk and leaves separately then put then together in studio. That should work

1 Like

And how would i do that ? The leaves are a vertex group of the tree, so i cant select just the tree and the leaves separatly no ? :confused: Im a beginner in blender, i just followed a tutorial to make a tree and i dont know how id do that haha
(Open the blend file if you dont understand what im saying :slight_smile: )

TLDR : basically idk how to select just the leaves of my model

1 Like

Could you send me the textures for both the trunk and leaves?

If you need to seperate the leaves from the trunk if it’s in the same mesh, you can press p to go into selection mode and make it a seperate object:


1 Like

Problem is that I used the particle settings to make the leaf so i can’t select the leaves in edit mode … So i can’t separate the leaves from the tree :confused:

There you go

Tree Test 2

Ok so I found how to separate the leaves from the tree (thx google) :

  1. select object that has hair .
  2. select convert Particle Modifier on modifiers tab.
  3. remove particle system under particles tab.

But I have another problem now haha, the leaves are not transparent… :cry:

any idea on how to resolve this ?

1 Like

Well after trying countless times and watching countless tutorials, I came to the conclusion that with the method I used to create the tree, i think it is NOT possible to keep the transparency in the leaf, so add the tree from blender then add the leaves manually in roblox with decals.

PS : I was wrong xd

Actually if you set the transparency of the leaves to 0.02 it should make the black bits disappear leaving just the leaves. Hope this helps


This is actually the solution haha thank you so much ! :smiley:

Can’t believe I didn’t even try that