Can't log in to Roblox Studio

All day today I have been trying to log into Roblox Studio. I am able to get passed 2 step verification but then it gets stuck with these 3 dots. I’ve tried restarting, re-installing and clearing the appdata folder. I desperately need to get into studio so any help is much appreciated, thank you in advance.


Hi, try this:

  1. Open your session in a web browser

  2. Go to

  3. In a personal or group Experiences click the tumbnail, then press “Edit in Studio”

  4. Studio will open automatically (if the browser asks you press Yes)

  5. You will see 2 options: Login through the browser and through Studio. Press Browser Login

  6. A page will open asking if you want to log in with your account, press accept and studio should open automatically (again, if your browser asks press yes)

  7. Enjoy!

If you have any questions or problems feel free to ask me.

Good luck!


Thank you, this worked! I also just found out that using a direct ethernet cable to my router fixes the issue, so it my internet may be part of it :stuck_out_tongue:

im having a similar problem, but the post solution has not worked for me
given what ive seen on the devforum, this is a fairly widespread issue

i would try this as well, but given where my pc is situated, this is not something i can do

i have tried my own solutions that have worked in the past

for those interested, here they are

literally reinstall studio:

  • i dont need to give you a walkthrough for this

clear windows login credentials:

  • open control panel
  • click user accounts
  • click manage windows credentials
  • scroll down and find any that say roblox
  • remove all of them

those usually fix my issues, but in this case have not

edit: if you are still having issues after all of this, try running as administrator

1 Like

instead of replying to solved question, simply make new post, because it will be automatically closed after 14 days and mostly no one looking into already solved topics

im not a regular, i cant do that

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.