Can't make a Developer Product

I Can’t make a Developer Product it gives me a 403 error
I tried everything reinstalling the studio and making a new place but all of these tries didn’t work please help

1 Like

It happens to me yesterday when I was editing Button Simulator.

So the only way to create the Dev Products, is to go to Create Roblox.

But also, it cannot load your experiences since Roblox’s down, should have replied here earlier (seems like it’s practically working).

1 Like

You cant create Developer products because Roblox is down and again reached the Roblox CCUs


1 Like

It may be that you have something wrong with your game description, had it yesterday also went but also because I changed my game name like my game description. Try this a few mall maybe it goes again. if not work than sorry that I couldn’t help.

Thanks, It worked, I can’t create a Developer Product from Roblox studio but I can from Roblox create

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.