Can't make game public

A really old game of mine is currently broken, and I was wondering how I could get it fixed. For a few years now, I get an error when trying to make it public. I can’t fix this on my end.

Here’s a gif of me trying to make it public:

Here’s the place in question:

I’m curious as to how and why this happening. Never seen it before other than this. Been this way for years now.


You could try relocating the game.

Id try that and if it doesn’t work contact roblox maybe? Or it has something that may be against guidelines,

If I were to do that, would the DataStores and products transfer over? That’s a concern of mine, as the only reason I want to bring it back is for the old players to revisit a relic of the past. If their data isn’t there, it isn’t viable for me to bother, the game will never be updated again. It’s just for the old players to revisit history essentially, I get questions from them asking what happened to it all the time.

Another game of mine got put under review for unfiltered chat. This game too had unfiltered chat, but never got put under review. I privated the game to stop it from being put under review but never updated it to fix the chat, and I briefly unprivated it a few times in ~2017 for a few minutes and it worked just fine. All assets in the game were custom made so there is definitely no copyright infringement. One day, I fixed the chat, but I just couldn’t make it public anymore and got this error ever since. usually just responds with copy paste messages and isn’t very helpful, I could try dev relations, I just wasn’t sure the best place to bring it up. I assumed perhaps there’s a bug on the website-end causing this, and that’s why I posted it here.

Edit: it’s not a huge deal to me even if I can’t recover the game; I just find it weird how one day it was stuck in private mode.

1 Like

Sadly yes the DataStores will not transfer. Are you talking Dev Products? This then again I’m a graphic designer so this is not my strong point but I also do Building so :man_shrugging: will sometimes actually respond with a valid answer or they will lead to a somewhat relevant post here.

Try changing the name, maybe its beacuse of filter.


Does it have a starting place correctly defined? Check under the places tab of the configuration page. If no starting place is selected, then select one.

Also does it open in studio? If so you can try changing access from within studio.

1 Like

Is it archived? If so, unarchive it


It does have a starting place:

And yes, it opens perfectly fine in Studio. I still get an error there, too:

It is not archived, no.

Tried this, the name doesn’t matter. It’ll successfully turn to hashtags if I change it to something that doesn’t pass filter, but regardless of what the name is, the place can’t be made active.

Edit: Also tried the description too as that previously contained text that wasn’t allowed anymore.

I also noticed it’s still paid access; I disabled paid access, but still can’t make the game public.

The configure page for the starting place is set to “Everyone” as seen below:

1 Like

My 2 cents:

Roblox could have had different active states in the past for places and universes, try making the game and places synchronized, unactive, then try to activate, with maybe even trying the api directly:!/v1

Great idea! Using the API directly yielded a different result:

  "errors": [
      "code": 6,
      "message": "The root place for this universe is under review and can not be activated.",
      "userFacingMessage": "Something went wrong",
      "field": "universeId"

But, the place doesn’t show as under review. So from here, would I have to email roblox about this? Would be the correct place to direct my email?

Thank you for your suggestion, I hadn’t thought about using the API, at least now I know why I can’t make it active anymore. A great first step to reaching a resolution.

Edit: Should this thread be moved in that case? It’s still sort of a bug in itself that it didn’t tell me it wasn’t able to activate due to under review, nor does it display as under review on the game’s page itself. I spent a few years wondering why I couldn’t activate this place, all along, it’s because it went under review while inactive. That is a bug in itself, yes?

That’s what caused this in the first place; I made it inactive, then it went under review.

Edit 2: I adjusted the thread to reflect the newly learned information, as I indeed believe this is still a bug and this thread is still valid here.

Please do not edit the original post, instead mark a reply as a solution, otherwise it would confuse those who are searching for the same problem.

While having your place under review while inactive seems strange, specially due to lack of user feedback about it on the website, it may not be a bug internally, you should resolve the place review normally, first by fixing the offending components, for example, lack of chat filter, and then contacting roblox.


Well, I just saw this:



This rules out my idea of it being under review before this thread. So I’m still uncertain why it wasn’t able to be public, but I’m going through the review process for it. Maybe they fixed something internally on their end; clearly they investigated the game.

Dealing with this same issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.